3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
46 lines
1.6 KiB
Text
46 lines
1.6 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
# Maintainer: Minecrell <minecrell@minecrell.net>
|
|
pkgname=device-motorola-harpia
|
|
pkgdesc="Motorola Moto G4 Play"
|
|
pkgver=9
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="postmarketos-base mkbootimg linux-postmarketos-qcom-msm8916
|
|
soc-qcom-msm8916 soc-qcom-msm8916-rproc"
|
|
makedepends="devicepkg-dev"
|
|
source="deviceinfo modules-initfs"
|
|
subpackages="
|
|
$pkgname-nonfree-firmware:nonfree_firmware
|
|
"
|
|
_pmb_select="soc-qcom-msm8916-rproc"
|
|
|
|
# Backwards compatibility for old kernel variant subpackages
|
|
replaces="$pkgname-kernel-mainline $pkgname-kernel-mainline-modem"
|
|
for pkg in $replaces; do provides="$provides $pkg=$pkgver-r$pkgrel"; done
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
|
|
# harpia's WCNSS firmware has problems with WiFi channels on some device
|
|
# variants, using osprey's firmware seems to help as a workaround
|
|
# (see https://gitlab.com/postmarketOS/pmaports/-/issues/1085)
|
|
depends="firmware-qcom-adreno-a300 msm-firmware-loader
|
|
firmware-motorola-harpia-wcnss-nv firmware-motorola-harpia-venus
|
|
firmware-motorola-osprey-wcnss"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
31eba51ab586af61d0ea0efb2e0f0a8533524254e864d59bc2142ba30c6b5745a46a00314fbf86a8b5bcfeee2d42b218c27d2e8aa5ed19f24e50468860999e56 deviceinfo
|
|
525a3e20672a7dff26b885b99ee157e0ece33efa10db34c90aed45dc47d7f1c2e90d7082dc84f2724892f199b5adaca04d5864f0aa1d1e4b8ea695f840346d60 modules-initfs
|
|
"
|