samsung-gtaxlwifi: new device (MR 2796)
This commit is contained in:
parent
c3856bad33
commit
cfa3414d3e
5 changed files with 4783 additions and 0 deletions
29
device/testing/device-samsung-gtaxlwifi/APKBUILD
Normal file
29
device/testing/device-samsung-gtaxlwifi/APKBUILD
Normal file
|
@ -0,0 +1,29 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-samsung-gtaxlwifi
|
||||
pkgdesc="Samsung Galaxy Tab A 2016 (SM-T580)"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="aarch64"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-samsung-gtaxlwifi
|
||||
mesa-dri-gallium
|
||||
mkbootimg
|
||||
postmarketos-base
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
113b58f69644e827a67dd2e8b95fc9605c69fd7c52241282c7bbcafbe94aad65c1de6888709b2fae5797d74256f6c386efaa4a4f8ea40ada2a72403babdb3cf5 deviceinfo
|
||||
"
|
35
device/testing/device-samsung-gtaxlwifi/deviceinfo
Normal file
35
device/testing/device-samsung-gtaxlwifi/deviceinfo
Normal file
|
@ -0,0 +1,35 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Samsung Galaxy Tab A 2016 (SM-T580)"
|
||||
deviceinfo_manufacturer="Samsung"
|
||||
deviceinfo_codename="samsung-gtaxlwifi"
|
||||
deviceinfo_year="2016"
|
||||
deviceinfo_arch="aarch64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="tablet"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="1200"
|
||||
deviceinfo_screen_height="1920"
|
||||
deviceinfo_gpu_accelerated="true"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="heimdall-bootimg"
|
||||
deviceinfo_kernel_cmdline="androidboot.selinux=permissive androidboot.selinux=permissive"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="true"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_flash_offset_base="0x10000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_heimdall_partition_kernel="BOOT"
|
||||
deviceinfo_flash_heimdall_partition_system="SYSTEM"
|
||||
deviceinfo_flash_sparse="true"
|
15
device/testing/linux-samsung-gtaxlwifi/01-fix-dtb.patch
Normal file
15
device/testing/linux-samsung-gtaxlwifi/01-fix-dtb.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
diff --git a/arch/arm64/boot/dts/Makefile b/arch/arm64/boot/dts/Makefile
|
||||
index b585e4f4c..cacea1aa8 100644
|
||||
--- a/arch/arm64/boot/dts/Makefile
|
||||
+++ b/arch/arm64/boot/dts/Makefile
|
||||
@@ -5,6 +5,10 @@ dtb-$(CONFIG_SOC_EXYNOS8890) += exynos8890-espresso8890.dtb exynos8890-espresso8
|
||||
dtb-$(CONFIG_SOC_EXYNOS8890) += exynos8890-evt1-smdk8890.dtb
|
||||
dtb-$(CONFIG_SOC_EXYNOS7870) += exynos7870-smdk7870.dtb exynos7870-universal7870.dtb exynos7870-universal7870_rev01.dtb exynos7870-universal7870_rev01_treble_off.dtb exynos7870-universal7870_go.dtb
|
||||
|
||||
+dtb-$(CONFIG_SOC_EXYNOS7870) += exynos7870-gtaxlwifi_eur_open_00.dtb \
|
||||
+exynos7870-gtaxlwifi_eur_open_04.dtb \
|
||||
+exynos7870-gtaxlwifi_eur_open_05.dtb
|
||||
+
|
||||
targets += dtbs
|
||||
|
||||
DTB_NAMES := $(subst $\",,$(CONFIG_BUILD_ARM64_APPENDED_DTB_IMAGE_NAMES))
|
62
device/testing/linux-samsung-gtaxlwifi/APKBUILD
Normal file
62
device/testing/linux-samsung-gtaxlwifi/APKBUILD
Normal file
|
@ -0,0 +1,62 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm64/configs/lineage-gtaxlwifi_defconfig
|
||||
|
||||
pkgname=linux-samsung-gtaxlwifi
|
||||
pkgver=3.18.140
|
||||
pkgrel=0
|
||||
pkgdesc="Samsung Galaxy Tab A 2016 (SM-T580) kernel fork"
|
||||
arch="aarch64"
|
||||
_carch="arm64"
|
||||
_flavor="samsung-gtaxlwifi"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
dtbtool-exynos
|
||||
flex
|
||||
openssl-dev
|
||||
perl
|
||||
"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_samsung_exynos7870"
|
||||
_commit="d8deb7266a4aa634bc0b96bb9a10fb9c335cc6e2"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/TALUAtGitHub/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
01-fix-dtb.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
|
||||
# Master DTB (deviceinfo_bootimg_qcdt)
|
||||
dtbTool-exynos -o "$_outdir/arch/$_carch/boot"/dt.img \
|
||||
$(find "$_outdir/arch/$_carch/boot/dts/" -name *gtaxlwifi*.dtb)
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" \
|
||||
"$_flavor" "$_outdir"
|
||||
install -Dm644 "$_outdir/arch/$_carch/boot"/dt.img \
|
||||
"$pkgdir"/boot/dt.img
|
||||
}
|
||||
sha512sums="
|
||||
b082900b4ad45f26913dbc705675ceaaed2fca6be20f8699f3c3d7e42f042e9d3db49c18b5ff16bff501cc68522e710f08ea61b73292668e27c8dc29fe9f26bd linux-samsung-gtaxlwifi-d8deb7266a4aa634bc0b96bb9a10fb9c335cc6e2.tar.gz
|
||||
2a1fb550c4bef1de90ad233af1ed5a29cded7fb77a3ab881707d8f9dd9660fd108ed32f67891a674291661baecc3e1eca4c51a1a4ff66b515bf786db9a4e7d06 config-samsung-gtaxlwifi.aarch64
|
||||
f10b3ddf297144739c8538bfb7998f19d8aec65e458e8dbe6ef400ffd9dfa845f042f481902dd0d38c97b2cc9c431db7722bccfbdf46bb6d340810bb981a8918 01-fix-dtb.patch
|
||||
"
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue