mobvoi-skipjack: new device (MR 2804)

This commit is contained in:
ptrcnull 2021-12-30 11:57:28 +01:00 committed by Luca Weiss
parent 9abe7e28b2
commit c3856bad33
No known key found for this signature in database
GPG key ID: 72D843B89D4DD756
7 changed files with 4291 additions and 0 deletions

View file

@ -0,0 +1,30 @@
# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-mobvoi-skipjack
pkgdesc="Mobvoi Ticwatch C2"
pkgver=0.1
pkgrel=0
url="https://postmarketos.org"
license="MIT"
arch="armv7"
options="!check !archcheck"
depends="
linux-mobvoi-skipjack
mesa-dri-gallium
mkbootimg
postmarketos-base
mdss-fb-init-hack
"
makedepends="devicepkg-dev"
source="deviceinfo"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
sha512sums="
8ec2903bf1c6ebd955fd22fdf1883b7bfdef2d9c58d8f68a81c46de2b2554e10f45671f0de0b35165aa53b270fd6938d78040c2a74b9044b5d32c05afef4f9f5 deviceinfo
"

View file

@ -0,0 +1,32 @@
# Reference: <https://postmarketos.org/deviceinfo>
# Please use double quotes only. You can source this file in shell
# scripts.
deviceinfo_format_version="0"
deviceinfo_name="Mobvoi Ticwatch C2"
deviceinfo_manufacturer="Mobvoi"
deviceinfo_codename="mobvoi-skipjack"
deviceinfo_year="2018"
deviceinfo_arch="armv7"
# Device related
deviceinfo_chassis="watch"
deviceinfo_keyboard="false"
deviceinfo_external_storage="false"
deviceinfo_screen_width="360"
deviceinfo_screen_height="360"
# Bootloader related
deviceinfo_flash_method="fastboot"
deviceinfo_flash_sparse="true"
deviceinfo_kernel_cmdline="androidboot.hardware=skipjack msm_rtb.filter=0x237 ehci-hcd.park=3 lpm_levels.sleep_disabled=1 androidboot.selinux=permissive buildvariant=eng"
deviceinfo_generate_bootimg="true"
deviceinfo_bootimg_qcdt="false"
deviceinfo_bootimg_mtk_mkimage="false"
deviceinfo_bootimg_dtb_second="false"
deviceinfo_flash_pagesize="2048"
deviceinfo_flash_offset_base="0x80100000"
deviceinfo_flash_offset_kernel="0x00008000"
deviceinfo_flash_offset_ramdisk="0x02000000"
deviceinfo_flash_offset_second="0x00f00000"
deviceinfo_flash_offset_tags="0x01e00000"

View file

@ -0,0 +1,60 @@
# Reference: <https://postmarketos.org/vendorkernel>
# Kernel config based on: arch/arm/configs/skipjack-perf_defconfig
pkgname=linux-mobvoi-skipjack
pkgver=3.18.24
pkgrel=0
pkgdesc="Mobvoi Ticwatch C2 kernel fork"
arch="armv7"
_carch="arm"
_flavor="mobvoi-skipjack"
url="https://kernel.org"
license="GPL-2.0-only"
options="!strip !check !tracedeps pmb:cross-native"
makedepends="
bash
bc
bison
devicepkg-dev
flex
openssl-dev
perl
"
# Source
_commit="a3099f57d3d213992f2b123503b18d91975c7875"
_config="config-$_flavor.$arch"
source="
$pkgname-$_commit.tar.gz::https://github.com/aosp-mirror/kernel_msm/archive/$_commit.tar.gz
$_config
gcc8-fix-put-user.patch
gcc10-extern_YYLOC_global_declaration.patch
touchscreen-disable-extlibs.patch
"
builddir="$srcdir/kernel_msm-$_commit"
_outdir="out"
prepare() {
default_prepare
. downstreamkernel_prepare
}
build() {
unset LDFLAGS
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
}
package() {
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" \
"$_flavor" "$_outdir"
}
sha512sums="
c829f18294b0fa257bfcb527ff1db2258f315e2e2e3686d37e9a1b78ab179603913f5c2127974e41ce68f033dbd0e9da0e1f9358f6d8b6a21b08bd26a43323ab linux-mobvoi-skipjack-a3099f57d3d213992f2b123503b18d91975c7875.tar.gz
555faef812338b20752f42f39e364defd6a6b46b5f9ae0b8f2301bee6ab6427a0558b80f3bd13e8a2c86a32a6c99f71c5a4e37aa745574e97ffbbb907b02e303 config-mobvoi-skipjack.armv7
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
dfc8d43166e57c8aa5419fb59823ed3dfaf6fa0a751c1d0b172984d24203c521a4373cc4054a115a9d46cfb89e7505fc66e164510ce9b98701f68a24253f1a1c touchscreen-disable-extlibs.patch
"

File diff suppressed because it is too large Load diff

View file

@ -0,0 +1 @@
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch

View file

@ -0,0 +1 @@
../../.shared-patches/linux/gcc8-fix-put-user.patch

View file

@ -0,0 +1,22 @@
From aee3bc1c9b37c55db341d68f1d6eb4e29e39d7a9 Mon Sep 17 00:00:00 2001
From: MagneFire <IDaNLContact@gmail.com>
Date: Fri, 8 Oct 2021 23:36:39 +0200
Subject: [PATCH] touchscreen: Disable extlibs
---
drivers/input/touchscreen/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/input/touchscreen/Makefile b/drivers/input/touchscreen/Makefile
index e6345311f42..e80a0b75cc8 100644
--- a/drivers/input/touchscreen/Makefile
+++ b/drivers/input/touchscreen/Makefile
@@ -93,4 +93,4 @@ obj-$(CONFIG_TOUCHSCREEN_FT3267) += fts_ts.o
fts_ts-$(CONFIG_TOUCHSCREEN_FT3267) += focaltech_core.o focaltech_ctl.o focaltech_ex_fun.o focaltech_flash.o \
test_lib.o ini.o Global.o Config_FT6X36.o Test_FT6X36.o DetailThreshold.o focaltech_gesture.o
ldflagobj-$(CONFIG_TOUCHSCREEN_FT3267) += fts_ts.o
-obj-$(CONFIG_TOUCHSCREEN_FT3267) s-$(CONFIG_TOUCHSCREEN_FT3267) +=--whole-archive $(extlibs) --no-whole-archive
+#obj-$(CONFIG_TOUCHSCREEN_FT3267) s-$(CONFIG_TOUCHSCREEN_FT3267) +=--whole-archive $(extlibs) --no-whole-archive
--
2.33.0