device/linux-lg-vee7e: fix build with new binutils
[ci:skip-build]: already built successfully in CI
This commit is contained in:
parent
37123b4fdb
commit
11e2b269ab
2 changed files with 33 additions and 2 deletions
|
@ -0,0 +1,29 @@
|
|||
From c8665661430f8c2e036d5e9f0e53f3df6d4d6fd9 Mon Sep 17 00:00:00 2001
|
||||
From: Luca Weiss <luca@z3ntu.xyz>
|
||||
Date: Wed, 6 Nov 2019 22:44:03 +0100
|
||||
Subject: [PATCH] Makefile: fix build with new binutils
|
||||
|
||||
Recent binutils complain when the linker script is passed multiple
|
||||
times, which is the case here:
|
||||
|
||||
error: linker script file '/<cut>/scripts/module-common.lds' appears multiple times
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index bf5d6523a10..bee6c13a237 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -365,7 +365,7 @@ CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \
|
||||
-Wbitwise -Wno-return-void $(CF)
|
||||
CFLAGS_MODULE = $(ARM_FLAGS) -DMODULE
|
||||
AFLAGS_MODULE = $(ARM_FLAGS) -DMODULE --strip-debug
|
||||
-LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds
|
||||
+LDFLAGS_MODULE =
|
||||
CFLAGS_KERNEL = $(ARM_FLAGS) -ftree-vectorize
|
||||
AFLAGS_KERNEL =
|
||||
CFLAGS_GCOV = -fprofile-arcs -ftest-coverage
|
||||
--
|
||||
2.24.0
|
||||
|
|
@ -3,7 +3,7 @@
|
|||
|
||||
pkgname="linux-lg-vee7e"
|
||||
pkgver=3.4.0
|
||||
pkgrel=0
|
||||
pkgrel=1
|
||||
pkgdesc="LG Optimus L7 II kernel fork"
|
||||
arch="armhf"
|
||||
_carch="arm"
|
||||
|
@ -29,6 +29,7 @@ source="
|
|||
static-inline-in-ftrace.h.patch
|
||||
01_timeconst_fix.patch
|
||||
02_gpu-msm-fix-gcc5-compile.patch
|
||||
0001-Makefile-fix-build-with-new-binutils.patch
|
||||
"
|
||||
builddir="$srcdir/${_repository}-${_commit}"
|
||||
|
||||
|
@ -69,4 +70,5 @@ sha512sums="0124de18237d4ea6a367aab9b6474a05bc67a5db18f687b8f58d3a8a63d2569b3ea9
|
|||
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||
ea1d3b5a234fa565e3c1a792de48f4fc4e6023d281d303c8e319c7ef28edc5739ab0e4dea0139a41f0a5c7d03e27921ccaa214fd0ac5c72245a094ce60128864 static-inline-in-ftrace.h.patch
|
||||
a2bb98fb8d988bbb659cae00fbaca360828300e9b98b90aed5ee0dd839c3f740696df4094a9021b813cbada06820d115aabed581a47cdd2c947e8d853c20b145 01_timeconst_fix.patch
|
||||
7be03a9e78b7ac330a54b1f00509caa0621a95c0c55901878ad757f9dd69cc05ba2c8b5ea987063ae1224f92c4d090d515fa5d369e7755181a4871b0d0f82881 02_gpu-msm-fix-gcc5-compile.patch"
|
||||
7be03a9e78b7ac330a54b1f00509caa0621a95c0c55901878ad757f9dd69cc05ba2c8b5ea987063ae1224f92c4d090d515fa5d369e7755181a4871b0d0f82881 02_gpu-msm-fix-gcc5-compile.patch
|
||||
ea8d5913bb28a2e1b7a22e7e2257c90b21b20382c4a08254b12dda1592c20cb5ec59ed4047ee8890380739889a7365ca087c398581f8702568d3cd575a59d158 0001-Makefile-fix-build-with-new-binutils.patch"
|
||||
|
|
Loading…
Reference in a new issue