device/linux-htc-bravo: fix build with new binutils

This commit is contained in:
Luca Weiss 2019-11-06 22:45:24 +01:00 committed by Oliver Smith
parent a185318feb
commit 37123b4fdb
No known key found for this signature in database
GPG key ID: 5AE7F5513E0885CB
2 changed files with 33 additions and 2 deletions

View file

@ -0,0 +1,29 @@
From 1438b6973b3cb8ed3f0bd726edf51354eec40149 Mon Sep 17 00:00:00 2001
From: Luca Weiss <luca@z3ntu.xyz>
Date: Wed, 6 Nov 2019 22:44:03 +0100
Subject: [PATCH] Makefile: fix build with new binutils
Recent binutils complain when the linker script is passed multiple
times, which is the case here:
error: linker script file '/<cut>/scripts/module-common.lds' appears multiple times
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 5732638bf57..930acff3dcf 100644
--- a/Makefile
+++ b/Makefile
@@ -360,7 +360,7 @@ CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \
MODFLAGS = -DMODULE -march=armv7-a -mtune=cortex-a8 -mfpu=neon -ftree-vectorize -ffast-math -fsingle-precision-constant
CFLAGS_MODULE = $(MODFLAGS)
AFLAGS_MODULE = $(MODFLAGS) -pipe
-LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds
+LDFLAGS_MODULE =
CFLAGS_KERNEL = -march=armv7-a -mtune=cortex-a8 -mfpu=neon -ftree-vectorize -ffast-math -fsingle-precision-constant
AFLAGS_KERNEL = -march=armv7-a -mtune=cortex-a8 -mfpu=neon -ftree-vectorize -ffast-math -fsingle-precision-constant -pipe
CFLAGS_GCOV = -fprofile-arcs -ftest-coverage
--
2.24.0

View file

@ -2,7 +2,7 @@
pkgname="linux-htc-bravo"
pkgver=3.0.16
pkgrel=10
pkgrel=11
pkgdesc="HTC Desire kernel from spezi77"
arch="armhf"
_carch="arm"
@ -29,6 +29,7 @@ source="
$pkgname-$_commit.tar.gz::https://github.com/spezi77/${_repository}/archive/${_commit}.tar.gz
$_config
compiler-gcc6.h
0001-Makefile-fix-build-with-new-binutils.patch
"
builddir="$srcdir/${_repository}-${_commit}"
@ -58,4 +59,5 @@ package() {
sha512sums="94929945d6fcb4428f320325ced207a9888cd758357766ef914c4ca2d5cea4b9cced77275463dac316591ba942e6e1514fec8c1f8e11c8324155116785ffb277 linux-htc-bravo-4bc19919f805777947c243e6c2ed41ece530488b.tar.gz
49460380237b391b9e0b79e3bad3ff65ea423a8ed0790501ae4c69652ff0799f21fa639bcb14014df81b5bbe361d0bf4665233d562d84047598bfca51b16dfc4 config-htc-bravo.armhf
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h"
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h
d287d21a02c8ec299619db7cd4e5f8669dc3107cd13c4d918a656a6d410d7cfa0d2fdfa3a4bd7b52982698e93ad63052cbc3be20c451ef224331bf325af9f813 0001-Makefile-fix-build-with-new-binutils.patch"