backports/coin: new aport
This commit is contained in:
parent
56634a3f6d
commit
892393bbb1
2 changed files with 47 additions and 0 deletions
36
backports/coin/APKBUILD
Normal file
36
backports/coin/APKBUILD
Normal file
|
@ -0,0 +1,36 @@
|
||||||
|
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
|
||||||
|
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
|
||||||
|
pkgname=coin
|
||||||
|
pkgver=4.0.0
|
||||||
|
pkgrel=5
|
||||||
|
pkgdesc="OpenGL OpenInventor compatible graphics library"
|
||||||
|
url="https://github.com/coin3d/coin"
|
||||||
|
license="BSD-3-Clause"
|
||||||
|
arch="all !armv7"
|
||||||
|
makedepends="boost-dev cmake glu-dev graphviz samurai"
|
||||||
|
subpackages="$pkgname-dev"
|
||||||
|
source="https://github.com/coin3d/coin/releases/download/Coin-$pkgver/coin-$pkgver-src.tar.gz
|
||||||
|
TestSuitePatch.patch
|
||||||
|
"
|
||||||
|
builddir="$srcdir/coin"
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cmake -B build -G Ninja \
|
||||||
|
-DCMAKE_BUILD_TYPE=Release \
|
||||||
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||||
|
-DCOIN_BUILD_TESTS=ON
|
||||||
|
cmake --build build
|
||||||
|
}
|
||||||
|
|
||||||
|
check() {
|
||||||
|
cmake --build build --target test
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
DESTDIR="$pkgdir" cmake --install build
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="
|
||||||
|
e036276a243bfe252569cee1b67d38b8633fcf35bdf4e366a92ca67e23799d54d91fe272c23b383c451d330cee284809f28f237857493948149e0da1ebd64fae coin-4.0.0-src.tar.gz
|
||||||
|
aab464244b13371badf0878e5bfbcce859a42756cf8c7657d1480318aa291d296eac2741219c346bae056f761c5f46857f8fd1ec1c4129f86bc10236d3869deb TestSuitePatch.patch
|
||||||
|
"
|
11
backports/coin/TestSuitePatch.patch
Normal file
11
backports/coin/TestSuitePatch.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- ./testsuite/TestSuiteUtils.cpp
|
||||||
|
+++ ./testsuite/TestSuiteUtils.cpp
|
||||||
|
@@ -39,7 +39,7 @@
|
||||||
|
#elif defined(_WIN32)
|
||||||
|
#define USE_WIN32
|
||||||
|
#else //_WIN32
|
||||||
|
-#error Unknown system
|
||||||
|
+#define USE_POSIX
|
||||||
|
#endif //POSIX
|
||||||
|
|
||||||
|
#include <Inventor/errors/SoDebugError.h>
|
Loading…
Reference in a new issue