backports/py3-pivy: new aport
This commit is contained in:
parent
9b33be18a3
commit
56634a3f6d
2 changed files with 52 additions and 0 deletions
41
backports/py3-pivy/APKBUILD
Normal file
41
backports/py3-pivy/APKBUILD
Normal file
|
@ -0,0 +1,41 @@
|
|||
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
|
||||
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
|
||||
pkgname=py3-pivy
|
||||
_pkgname=pivy
|
||||
pkgver=0.6.8
|
||||
pkgrel=2
|
||||
pkgdesc="Python3 bindings for coin"
|
||||
url="https://github.com/coin3d/pivy"
|
||||
# riscv64 blocked by qt5-qtwebengine via py3-pyside2
|
||||
# py3-pyside2 is not available on armhf
|
||||
arch="all !armhf !riscv64 !armv7"
|
||||
license="ISC"
|
||||
depends="py3-pyside2"
|
||||
makedepends="swig soqt-dev qt5-qtbase-dev python3-dev glu-dev cmake samurai"
|
||||
checkdepends="py3-pytest"
|
||||
options="!check" # test suite is interactive and requires full installation
|
||||
source="$pkgname-$pkgver.tar.gz::https://github.com/coin3d/pivy/archive/refs/tags/$pkgver.tar.gz
|
||||
qt5.patch
|
||||
"
|
||||
builddir="$srcdir/$_pkgname-$pkgver"
|
||||
|
||||
build() {
|
||||
if [ "$CBUILD" != "$CHOST" ]; then
|
||||
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
|
||||
fi
|
||||
cmake -B build -G Ninja \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DBUILD_SHARED_LIBS=True \
|
||||
-DCMAKE_BUILD_TYPE=None \
|
||||
$CMAKE_CROSSOPTS
|
||||
cmake --build build
|
||||
}
|
||||
|
||||
package() {
|
||||
DESTDIR="$pkgdir" cmake --install build
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
723b09028f2e3075056b9588cebad0ddccbc98d0c15552b9565c177b0de764b9645f88ea2bc534ccf606f2e0b59f91e1d03551b55ece66c0654ce9cdf09a1a7c py3-pivy-0.6.8.tar.gz
|
||||
7750ded3eb09da510ba5f84e7957c2ae1f92be0df280901fd9c9eba4164758a8f2d436e2d6ae7634a91aed12609f4eefd181922e6caed0b4906c6bc9dbd7b562 qt5.patch
|
||||
"
|
11
backports/py3-pivy/qt5.patch
Normal file
11
backports/py3-pivy/qt5.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./qtinfo.py
|
||||
+++ ./qtinfo.py
|
||||
@@ -7,7 +7,7 @@
|
||||
if qmake_command:
|
||||
self._qmake_command = qmake_command
|
||||
else:
|
||||
- self._qmake_command = [find_executable("qmake"),]
|
||||
+ self._qmake_command = [find_executable("qmake-qt5"),]
|
||||
self._dict = {}
|
||||
# bind all variables early at __init__ time.
|
||||
for thing in self.__class__.__dict__:
|
Loading…
Reference in a new issue