fb436c7b29
Adds an aport for unixbench and a wrapper so it can be started with ubench without requiring write permissions in /usr. To launch the benchmark on a phone and have it finish in a reasonable amount of time: $ ubench dhry whets Output on an i7-7700HQ in the pmbootstrap chroot: Dhrystone 2 using register variables 146273178.2 lps (10.0 s, 7 samples) Double-Precision Whetstone 44390.3 MWIPS (9.7 s, 7 samples) System Benchmarks Partial Index BASELINE RESULT INDEX Dhrystone 2 using register variables 116700.0 146273178.2 12534.1 Double-Precision Whetstone 55.0 44390.3 8071.0 ======== System Benchmarks Index Score (Partial Only) 10057.9 This is a neat way to get relative performance between devices and testing performance for upstream/downstream kernels.
12 lines
441 B
Diff
12 lines
441 B
Diff
diff -ruN UnixBench/Makefile b/Makefile
|
|
--- a/Makefile 2015-08-15 01:52:22.539585616 -0600
|
|
+++ b/Makefile 2015-08-15 02:00:13.772259951 -0600
|
|
@@ -71,7 +71,7 @@
|
|
# -m386 -malign-loops=1 -malign-jumps=1 -malign-functions=1
|
|
|
|
## For Solaris 2, or general-purpose GCC 2.7.x
|
|
-OPTON = -O2 -fomit-frame-pointer -fforce-addr -ffast-math -Wall
|
|
+OPTON = -O2 -ffast-math -Wall -march=native
|
|
|
|
## For Digital Unix v4.x, with DEC cc v5.x
|
|
#OPTON = -O4
|