8c2a95dbe2
* Mir starts up and is able to display system settings * x86_64 only for now, because at least ubuntu-app-test did not build on aarch64 Based on PureTryOut's work. Getting it to this stage was a huge effort (as it shows in the package count: 111(!)). See the merge request for details. [skip ci]: this won't finish in CI; ollieparanoid made sure that everything builds for x86_64.
20 lines
586 B
Diff
20 lines
586 B
Diff
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
|
index 32b3632..4661cbc 100644
|
|
--- a/src/CMakeLists.txt
|
|
+++ b/src/CMakeLists.txt
|
|
@@ -17,6 +17,7 @@
|
|
find_package(Qt5Core REQUIRED)
|
|
find_package(Qt5Qml REQUIRED)
|
|
find_package(Qt5Quick REQUIRED)
|
|
+find_package(Intl REQUIRED)
|
|
|
|
pkg_check_modules(DBUS_CPP dbus-cpp REQUIRED)
|
|
pkg_check_modules(DBUS dbus-1 REQUIRED)
|
|
@@ -108,6 +109,7 @@ if (TRUST_STORE_MIR_AGENT_ENABLED)
|
|
target_link_libraries(
|
|
trust-prompt
|
|
|
|
+ ${Intl_LIBRARIES}
|
|
Qt5::Core Qt5::Gui Qt5::Qml Qt5::Quick
|
|
${Boost_LIBRARIES}
|
|
${PROCESS_CPP_LDFLAGS}
|