c395f9c94b
Port based on an unofficial LineageOS port from https://www.los-legacy.de/17.1/zerofltexx, using kernel from https://github.com/Exynos7420/android_kernel_samsung_exynos7420/ What works: - Kernel boots - Display and touch input (tested with Weston) - USB networking Note: I removed camera support in kernel config for now, as there were related kernel crashes. Wifi doesn't work either yet because the firmware dependencies/paths need to be fixed first.
15 lines
552 B
Diff
15 lines
552 B
Diff
diff --git a/Makefile b/Makefile
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -197,11 +197,6 @@
|
|
CROSS_COMPILE ?= ../PLATFORM/prebuilts/gcc/linux-x86/aarch64/aarch64-linux-android-4.9/bin/aarch64-linux-android-
|
|
#CROSS_COMPILE ?= /opt/toolchains/aarch64-linux-android-4.9/bin/aarch64-linux-android-
|
|
|
|
-ifeq ($(shell uname -s),Linux)
|
|
- ifeq ($(shell uname -m),x86_64)
|
|
- override CROSS_COMPILE := $(srctree)/../../../prebuilts/linaro/linux-x86/aarch64/bin/aarch64-linux-gnu-
|
|
- endif
|
|
-endif
|
|
|
|
# Architecture as present in compile.h
|
|
UTS_MACHINE := $(ARCH)
|