pmaports/main/mesa-grate/0001-meson-Add-glx-tls-option.patch
2019-01-18 07:33:58 +01:00

40 lines
1.1 KiB
Diff

From 63a084c6c2b63cdfb577dfffe6432c91d145daf5 Mon Sep 17 00:00:00 2001
From: Robert Yang <decatf@gmail.com>
Date: Fri, 11 Jan 2019 14:26:55 -0500
Subject: [PATCH] meson: Add glx-tls option
---
meson.build | 5 ++++-
meson_options.txt | 6 ++++++
2 files changed, 10 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 0ecd14cc5c6..4014ac28948 100644
--- a/meson.build
+++ b/meson.build
@@ -340,7 +340,10 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless)
endif
endif
-pre_args += '-DGLX_USE_TLS'
+if get_option('glx-tls') != false
+ pre_args += '-DGLX_USE_TLS'
+endif
+
if with_glx != 'disabled'
if not (with_platform_x11 and with_any_opengl)
if with_glx == 'auto'
diff --git a/meson_options.txt b/meson_options.txt
index a573290b774..e1304293065 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -286,3 +286,9 @@ option(
value : '',
description : 'Comma delimited list of tools to build. choices : freedreno,glsl,intel,nir,nouveau or all'
)
+option(
+ 'glx-tls',
+ type : 'boolean',
+ value : true,
+ description : 'Enable TLS support in GLX'
+)