pmaports/main/linux-postmarketos-mainline/0002-tools-objtool-Makefile-don-t-assume-sync-check.sh-is.patch
Luca Weiss 988aef6646 Update linux-postmarketos-mainline to 4.15-rc6 (#1067)
* Using full diff skipping v4.15-rc1
cgit doesn't generate proper patches for binary files (one was added in
v4.15-rc1 and removed in v4.15-rc5 because it also introduced a new
build-time dependency which is now solved). For 4.16 the "old" source
lines can be re-added but until then a full diff skipping v4.15-rc1
is needed.
* Add patch from linux-next to fix the build on some machines
  (sync-check.sh was not executable, see #950)
2018-01-01 23:53:01 +00:00

33 lines
1 KiB
Diff

From c8c7e01bd7c7cb5a0811efef88dfe6b40e009348 Mon Sep 17 00:00:00 2001
From: Andrew Morton <akpm@linux-foundation.org>
Date: Fri, 15 Dec 2017 11:22:35 +1100
Subject: [PATCH] tools/objtool/Makefile: don't assume sync-check.sh is
executable
patch(1) loses the x bit. Kernel build breaks.
Fixes: 3bd51c5a371de ("objtool: Move kernel headers/code sync check to a script")
Cc: Ingo Molnar <mingo@kernel.org>
Cc: Josh Poimboeuf <jpoimboe@redhat.com>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Stephen Rothwell <sfr@canb.auug.org.au>
---
tools/objtool/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/objtool/Makefile b/tools/objtool/Makefile
index ae0272f9a091..e6acc281dd37 100644
--- a/tools/objtool/Makefile
+++ b/tools/objtool/Makefile
@@ -46,7 +46,7 @@ $(OBJTOOL_IN): fixdep FORCE
@$(MAKE) $(build)=objtool
$(OBJTOOL): $(LIBSUBCMD) $(OBJTOOL_IN)
- @./sync-check.sh
+ @$(CONFIG_SHELL) ./sync-check.sh
$(QUIET_LINK)$(CC) $(OBJTOOL_IN) $(LDFLAGS) -o $@
--
2.15.1