646e0b50df
- 0003-dts-pinetab-add-missing-bma223-ohci1.patch
The original patch added a node for BMA223 and a node for ohci1.
The former is already present in upstream, so the new patch
0003-dts-pinetab-add-missing-ohci1.patch only adds the latter.
- 0004-arm64-dts-allwinner-Add-bluetooth-node-to-the-PineTa.patch
The patch is now present in upstream so it has been removed.
However it's worth noting that upstream's node has the wake GPIOs
reversed from the original patch. The original patch added:
device-wake-gpios = <&r_pio 0 6 GPIO_ACTIVE_LOW>; /* PL6 */
host-wake-gpios = <&r_pio 0 5 GPIO_ACTIVE_HIGH>; /* PL5 */
... while upstream has:
device-wake-gpios = <&r_pio 0 5 GPIO_ACTIVE_LOW>; /* PL5 */
host-wake-gpios = <&r_pio 0 6 GPIO_ACTIVE_HIGH>; /* PL6 */
This has not been tested on a PineTab.
- 0005-dts-pinetab-make-audio-routing-consistent-with-pinep.patch
The first hunk of the patch is in upstream and has been removed.
- 0013-Revert-usb-quirks-Add-USB_QUIRK_RESET-for-Quectel-EG25G-Modem.patch
This patch reverted upstream commit that was present until v6.7
( f9e3e7ea4e
)
but is not present in v6.8, so the patch has been removed.
- 0014-usb-serial-option-add-reset-resume-callback-for-WWAN.patch
The patch is now present in upstream so it has been removed.
295 lines
6 KiB
Diff
295 lines
6 KiB
Diff
From 991a3d5522ca1c623eba4c1a16351ecf1d7fba44 Mon Sep 17 00:00:00 2001
|
|
From: Denis Burkov <hitechshell@mail.ru>
|
|
Date: Mon, 11 Mar 2024 18:23:39 +0500
|
|
Subject: [PATCH] ARM: dts: allwinner: sun5i-a13-pocketbook-614-plus: Add
|
|
initial devicetree
|
|
|
|
---
|
|
arch/arm/boot/dts/allwinner/Makefile | 2 +
|
|
.../sun5i-a13-pocketbook-614-plus.dts | 254 ++++++++++++++++++
|
|
2 files changed, 256 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/allwinner/sun5i-a13-pocketbook-614-plus.dts
|
|
|
|
diff --git a/arch/arm/boot/dts/allwinner/Makefile b/arch/arm/boot/dts/allwinner/Makefile
|
|
index 902b8f6752a0..f7eb88a5709b 100644
|
|
--- a/arch/arm/boot/dts/allwinner/Makefile
|
|
+++ b/arch/arm/boot/dts/allwinner/Makefile
|
|
@@ -62,6 +62,7 @@ dtb-$(CONFIG_MACH_SUN5I) += \
|
|
sun5i-a13-olinuxino.dtb \
|
|
sun5i-a13-olinuxino-micro.dtb \
|
|
sun5i-a13-pocketbook-touch-lux-3.dtb \
|
|
+ sun5i-a13-pocketbook-614-plus.dtb \
|
|
sun5i-a13-q8-tablet.dtb \
|
|
sun5i-a13-utoo-p66.dtb \
|
|
sun5i-gr8-chip-pro.dtb \
|
|
@@ -83,6 +84,7 @@ dtb-$(CONFIG_MACH_SUN5I) += \
|
|
sun5i-a13-olinuxino.dtb \
|
|
sun5i-a13-olinuxino-micro.dtb \
|
|
sun5i-a13-pocketbook-touch-lux-3.dtb \
|
|
+ sun5i-a13-pocketbook-614-plus.dtb \
|
|
sun5i-a13-q8-tablet.dtb \
|
|
sun5i-a13-utoo-p66.dtb \
|
|
sun5i-gr8-chip-pro.dtb \
|
|
diff --git a/arch/arm/boot/dts/allwinner/sun5i-a13-pocketbook-614-plus.dts b/arch/arm/boot/dts/allwinner/sun5i-a13-pocketbook-614-plus.dts
|
|
new file mode 100644
|
|
index 000000000000..cad9ce5f2a6f
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/allwinner/sun5i-a13-pocketbook-614-plus.dts
|
|
@@ -0,0 +1,254 @@
|
|
+// SPDX-License-Identifier: GPL-2.0+
|
|
+/*
|
|
+ * Copyright 2024 Denis Burkov <hitechshell@mail.ru>
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+#include "sun5i-a13.dtsi"
|
|
+#include "sunxi-common-regulators.dtsi"
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
+#include <dt-bindings/input/input.h>
|
|
+#include <dt-bindings/interrupt-controller/irq.h>
|
|
+
|
|
+/ {
|
|
+ model = "PocketBook 614 Plus";
|
|
+ compatible = "pocketbook,614-plus", "allwinner,sun5i-a13";
|
|
+
|
|
+ aliases {
|
|
+ serial0 = &uart1;
|
|
+ i2c0 = &i2c0;
|
|
+ i2c1 = &i2c1;
|
|
+ i2c2 = &i2c2;
|
|
+ rtc0 = &pcf8563;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial0:115200n8";
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&led_pins_pocketbook>;
|
|
+
|
|
+ led {
|
|
+ gpios = <&pio 4 8 GPIO_ACTIVE_LOW>; /* PE8 */
|
|
+ default-state = "on";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ gpio-keys {
|
|
+ compatible = "gpio-keys";
|
|
+ autorepeat;
|
|
+ label = "GPIO Keys";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pocketbook_btn_pins>;
|
|
+
|
|
+ key-right {
|
|
+ label = "Right";
|
|
+ linux,code = <KEY_NEXT>;
|
|
+ gpios = <&pio 6 9 GPIO_ACTIVE_LOW>; /* PG9 */
|
|
+ };
|
|
+
|
|
+ key-left {
|
|
+ label = "Left";
|
|
+ linux,code = <KEY_PREVIOUS>;
|
|
+ gpios = <&pio 6 10 GPIO_ACTIVE_LOW>; /* PG10 */
|
|
+ };
|
|
+ };
|
|
+
|
|
+ reg_3v3_mmc0: regulator-mmc0 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "vdd-mmc0";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pocketbook_reg_mmc0_pin>;
|
|
+ gpio = <&pio 4 4 GPIO_ACTIVE_LOW>; /* PE4 */
|
|
+ vin-supply = <®_vcc3v3>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&cpu0 {
|
|
+ cpu-supply = <®_dcdc2>;
|
|
+};
|
|
+
|
|
+&ehci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&i2c0 {
|
|
+ status = "okay";
|
|
+
|
|
+ axp209: pmic@34 {
|
|
+ compatible = "x-powers,axp209";
|
|
+ reg = <0x34>;
|
|
+ interrupts = <0>;
|
|
+ };
|
|
+};
|
|
+
|
|
+#include "axp209.dtsi"
|
|
+
|
|
+&i2c1 {
|
|
+ status = "okay";
|
|
+
|
|
+ pcf8563: rtc@51 {
|
|
+ compatible = "nxp,pcf8563";
|
|
+ reg = <0x51>;
|
|
+ #clock-cells = <0>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&i2c2 {
|
|
+ status = "okay";
|
|
+
|
|
+ /* Touchpanel is connected here. */
|
|
+};
|
|
+
|
|
+&lradc {
|
|
+ vref-supply = <®_ldo2>;
|
|
+ status = "okay";
|
|
+
|
|
+ button-300 {
|
|
+ label = "Down";
|
|
+ linux,code = <KEY_DOWN>;
|
|
+ channel = <0>;
|
|
+ voltage = <300000>;
|
|
+ };
|
|
+
|
|
+ button-700 {
|
|
+ label = "Up";
|
|
+ linux,code = <KEY_UP>;
|
|
+ channel = <0>;
|
|
+ voltage = <700000>;
|
|
+ };
|
|
+
|
|
+ button-1000 {
|
|
+ label = "Left";
|
|
+ linux,code = <KEY_LEFT>;
|
|
+ channel = <0>;
|
|
+ voltage = <1000000>;
|
|
+ };
|
|
+
|
|
+ button-1200 {
|
|
+ label = "Menu";
|
|
+ linux,code = <KEY_MENU>;
|
|
+ channel = <0>;
|
|
+ voltage = <1200000>;
|
|
+ };
|
|
+
|
|
+ button-1500 {
|
|
+ label = "Right";
|
|
+ linux,code = <KEY_RIGHT>;
|
|
+ channel = <0>;
|
|
+ voltage = <1500000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&mmc0 {
|
|
+ vmmc-supply = <®_3v3_mmc0>;
|
|
+ bus-width = <4>;
|
|
+ cd-gpios = <&pio 6 0 GPIO_ACTIVE_LOW>; /* PG0 */
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mmc2 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&mmc2_4bit_pc_pins>;
|
|
+ vmmc-supply = <®_vcc3v3>;
|
|
+ bus-width = <4>;
|
|
+ non-removable;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ohci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&otg_sram {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&pio {
|
|
+ led_pins_pocketbook: led-pin {
|
|
+ pins = "PE8";
|
|
+ function = "gpio_out";
|
|
+ };
|
|
+ pocketbook_btn_pins: pocketbook_btn_pins {
|
|
+ pins = "PG9", "PG10";
|
|
+ function = "gpio_in";
|
|
+ bias-pull-up;
|
|
+ };
|
|
+ pocketbook_reg_mmc0_pin: pocketbook_reg_mmc0_pin {
|
|
+ pins = "PE4";
|
|
+ function = "gpio_out";
|
|
+ };
|
|
+};
|
|
+
|
|
+®_dcdc2 {
|
|
+ regulator-always-on;
|
|
+ regulator-min-microvolt = <1000000>;
|
|
+ regulator-max-microvolt = <1500000>;
|
|
+ regulator-name = "vdd-cpu";
|
|
+};
|
|
+
|
|
+®_dcdc3 {
|
|
+ regulator-always-on;
|
|
+ regulator-min-microvolt = <1000000>;
|
|
+ regulator-max-microvolt = <1400000>;
|
|
+ regulator-name = "vdd-int-dll";
|
|
+};
|
|
+
|
|
+®_ldo1 {
|
|
+ regulator-name = "vdd-rtc";
|
|
+};
|
|
+
|
|
+®_ldo2 {
|
|
+ regulator-always-on;
|
|
+ regulator-min-microvolt = <3000000>;
|
|
+ regulator-max-microvolt = <3000000>;
|
|
+ regulator-name = "avcc";
|
|
+};
|
|
+
|
|
+®_ldo3 {
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ regulator-name = "vcc-wifi";
|
|
+};
|
|
+
|
|
+®_usb0_vbus {
|
|
+ status = "okay";
|
|
+ gpio = <&pio 6 12 GPIO_ACTIVE_HIGH>; /* PG12 */
|
|
+};
|
|
+
|
|
+®_usb1_vbus {
|
|
+ gpio = <&pio 6 11 GPIO_ACTIVE_HIGH>; /* PG11 */
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart1_pg_pins>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb_otg {
|
|
+ dr_mode = "otg";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb_power_supply {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&battery_power_supply {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usbphy {
|
|
+ usb0_id_det-gpios = <&pio 6 2 (GPIO_ACTIVE_HIGH | GPIO_PULL_UP)>; /* PG2 */
|
|
+ usb0_vbus_det-gpios = <&axp_gpio 1 GPIO_ACTIVE_HIGH>;
|
|
+ usb0_vbus-supply = <®_usb0_vbus>;
|
|
+ usb1_vbus-supply = <®_usb1_vbus>;
|
|
+ status = "okay";
|
|
+};
|
|
--
|
|
2.44.0
|
|
|