pmaports/main/directfb/0005-fix-tslib-configure.patch
clayton craft ed0caeeaef Add osk-sdl, directfb, sdl2, tslib (#419)
The sdl2 package is forked from upstream Alpine and:
1) adds directfb video support
2) adds a patch to work around a compile issue when directfb is enabled
2017-08-19 16:50:59 +00:00

14 lines
583 B
Diff

--- a/configure.in
+++ b/configure.in
@@ -2459,9 +2459,9 @@
enable_tslib=no
if test "$checkfor_tslib" = "yes"; then
- PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
+ PKG_CHECK_MODULES([TSLIB], [tslib >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
if test "$enable_tslib" = "no"; then
- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no
+ PKG_CHECK_MODULES([TSLIB], [tslib], [enable_tslib=yes], [enable_tslib=no
AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
fi
fi