737cff798a
Based on the last version from Alpine, but installed to /usr/gcc6 and with pretty much everything disabled except for the C compiler. We can probably throw out a lot of patches, and make the APKBUILD much smaller. But let's focus on making it possible to compile old kernels again first. There's still a lot to do for that, see #103.
18 lines
611 B
Diff
18 lines
611 B
Diff
2008-07-25 Magnus Granberg <zorry@ume.nu>
|
|
|
|
* include/libiberty.h (asprintf): Don't declare if defined as a macro
|
|
|
|
--- a/include/libiberty.h
|
|
+++ b/include/libiberty.h
|
|
@@ -609,8 +609,11 @@ extern int pwait (int, int *, int);
|
|
/* Like sprintf but provides a pointer to malloc'd storage, which must
|
|
be freed by the caller. */
|
|
|
|
+/* asprintf may be declared as a macro by glibc with __USE_FORTIFY_LEVEL. */
|
|
+#ifndef asprintf
|
|
extern int asprintf (char **, const char *, ...) ATTRIBUTE_PRINTF_2;
|
|
#endif
|
|
+#endif
|
|
|
|
#if !HAVE_DECL_VASPRINTF
|
|
/* Like vsprintf but provides a pointer to malloc'd storage, which
|