737cff798a
Based on the last version from Alpine, but installed to /usr/gcc6 and with pretty much everything disabled except for the C compiler. We can probably throw out a lot of patches, and make the APKBUILD much smaller. But let's focus on making it possible to compile old kernels again first. There's still a lot to do for that, see #103.
25 lines
713 B
Diff
25 lines
713 B
Diff
Enable -Wtrampolines by default.
|
|
|
|
|
|
--- a/gcc/common.opt
|
|
+++ b/gcc/common.opt
|
|
@@ -648,7 +648,7 @@ Common Var(warn_system_headers) Warning
|
|
Do not suppress warnings from system headers
|
|
|
|
Wtrampolines
|
|
-Common Var(warn_trampolines) Warning
|
|
+Common Var(warn_trampolines) Init(1) Warning
|
|
Warn whenever a trampoline is generated
|
|
|
|
Wtype-limits
|
|
--- a/gcc/doc/gcc.info
|
|
+++ b/gcc/doc/gcc.info
|
|
@@ -4021,6 +4021,8 @@ compiler warns that an unrecognized option is present.
|
|
and thus requires the stack to be made executable in order for the
|
|
program to work properly.
|
|
|
|
+ This warning is enabled by default in Gentoo.
|
|
+
|
|
'-Wfloat-equal'
|
|
Warn if floating-point values are used in equality comparisons.
|
|
|