pmaports/device/linux-huawei-cameron/01_use_linux_alpine_crosscompile.patch
JohnBergago b21caaeeb8
New device: huawei-cameron (Huawei Mediapad M5 pro) (!133)
The device boots, USB networking is available and the display does also
work, even though the default display brightness seems to be zero. More
information can be found in the wiki.
2019-01-09 08:19:40 +01:00

13 lines
636 B
Diff

diff --git a/drivers/hisi/tzdriver/Makefile b/drivers/hisi/tzdriver/Makefile
index 45521e25..799b61d3 100644
--- a/drivers/hisi/tzdriver/Makefile
+++ b/drivers/hisi/tzdriver/Makefile
@@ -19,7 +19,7 @@ $(obj)/cfc_data.o: $(obj)/cfc_data.c
$(obj)/cfc_data.c: $(src)/cfc_graphgen.py $(src)/cfc_graph.py $(src)/cfc_codegen.py $(src)/cfc_rule_parser.py $(src)/template $(obj)/rule.out
+python $(srctree)/$(src)/cfc_codegen.py $(obj)/rule.out > $@
$(obj)/rule.out: $(src)/rule.in
- aarch64-linux-android-cpp $(srctree)/$(src)/rule.in > $@
+ $(CROSS_COMPILE)cpp $(srctree)/$(src)/rule.in > $@
ccflags-y += -Idrivers/video/hisi/dss \