64035ac463
Prepare for better device categorization by moving everything to testing subdir first. [skip-ci]: chicken-egg problem: passing pmaports CI depends on pmbootstrap MR depends on this MR Related: postmarketos#16
520 lines
14 KiB
Diff
520 lines
14 KiB
Diff
From 4a165a7fca0de465672464243c56ba32dfa818fd Mon Sep 17 00:00:00 2001
|
|
From: ryang <decatf@gmail.com>
|
|
Date: Sat, 21 Apr 2018 09:33:37 -0400
|
|
Subject: [PATCH] Add tegra_wm8994 driver
|
|
|
|
(cherry picked from commit d58c0084b16491251b3871bfacbc070105eb9356)
|
|
Signed-off-by: Sergey Larin <cerg2010cerg2010@mail.ru>
|
|
---
|
|
sound/soc/tegra/Kconfig | 14 +
|
|
sound/soc/tegra/Makefile | 2 +
|
|
sound/soc/tegra/tegra_wm8994.c | 452 +++++++++++++++++++++++++++++++++
|
|
3 files changed, 468 insertions(+)
|
|
create mode 100755 sound/soc/tegra/tegra_wm8994.c
|
|
|
|
diff --git a/sound/soc/tegra/Kconfig b/sound/soc/tegra/Kconfig
|
|
index addadc827b91..f1018b271314 100644
|
|
--- a/sound/soc/tegra/Kconfig
|
|
+++ b/sound/soc/tegra/Kconfig
|
|
@@ -87,6 +87,20 @@ config SND_SOC_TEGRA_WM8903
|
|
boards using the WM8093 codec. Currently, the supported boards are
|
|
Harmony, Ventana, Seaboard, Kaen, and Aebl.
|
|
|
|
+config SND_SOC_TEGRA_WM8994
|
|
+ tristate "SoC Audio support for Tegra boards using a WM8994 codec"
|
|
+ depends on SND_SOC_TEGRA && I2C
|
|
+ select SND_SOC_TEGRA20_I2S if ARCH_TEGRA_2x_SOC
|
|
+ select SND_SOC_TEGRA30_I2S if ARCH_TEGRA_3x_SOC
|
|
+ select SND_SOC_TEGRA20_SPDIF if ARCH_TEGRA_2x_SOC
|
|
+ select SND_SOC_TEGRA30_SPDIF if ARCH_TEGRA_3x_SOC
|
|
+ select SND_SOC_SPDIF
|
|
+ select SND_SOC_TEGRA30_DAM if ARCH_TEGRA_3x_SOC
|
|
+ help
|
|
+ Say Y or M here if you want to add support for SoC audio on Tegra
|
|
+ boards using the WM8994 codec. Currently, the supported boards are
|
|
+ Samsung P3.
|
|
+
|
|
config SND_SOC_TEGRA_WM9712
|
|
tristate "SoC Audio support for Tegra boards using a WM9712 codec"
|
|
depends on SND_SOC_TEGRA && GPIOLIB
|
|
diff --git a/sound/soc/tegra/Makefile b/sound/soc/tegra/Makefile
|
|
index 2329b72c93e3..09d0b47db5af 100644
|
|
--- a/sound/soc/tegra/Makefile
|
|
+++ b/sound/soc/tegra/Makefile
|
|
@@ -23,6 +23,7 @@ snd-soc-tegra-rt5640-objs := tegra_rt5640.o
|
|
snd-soc-tegra-rt5677-objs := tegra_rt5677.o
|
|
snd-soc-tegra-wm8753-objs := tegra_wm8753.o
|
|
snd-soc-tegra-wm8903-objs := tegra_wm8903.o
|
|
+snd-soc-tegra-wm8994-objs := tegra_wm8994.o
|
|
snd-soc-tegra-wm9712-objs := tegra_wm9712.o
|
|
snd-soc-tegra-trimslice-objs := trimslice.o
|
|
snd-soc-tegra-alc5632-objs := tegra_alc5632.o
|
|
@@ -33,6 +34,7 @@ obj-$(CONFIG_SND_SOC_TEGRA_RT5640) += snd-soc-tegra-rt5640.o
|
|
obj-$(CONFIG_SND_SOC_TEGRA_RT5677) += snd-soc-tegra-rt5677.o
|
|
obj-$(CONFIG_SND_SOC_TEGRA_WM8753) += snd-soc-tegra-wm8753.o
|
|
obj-$(CONFIG_SND_SOC_TEGRA_WM8903) += snd-soc-tegra-wm8903.o
|
|
+obj-$(CONFIG_SND_SOC_TEGRA_WM8994) += snd-soc-tegra-wm8994.o
|
|
obj-$(CONFIG_SND_SOC_TEGRA_WM9712) += snd-soc-tegra-wm9712.o
|
|
obj-$(CONFIG_SND_SOC_TEGRA_TRIMSLICE) += snd-soc-tegra-trimslice.o
|
|
obj-$(CONFIG_SND_SOC_TEGRA_ALC5632) += snd-soc-tegra-alc5632.o
|
|
diff --git a/sound/soc/tegra/tegra_wm8994.c b/sound/soc/tegra/tegra_wm8994.c
|
|
new file mode 100755
|
|
index 000000000000..bf928d7f4813
|
|
--- /dev/null
|
|
+++ b/sound/soc/tegra/tegra_wm8994.c
|
|
@@ -0,0 +1,452 @@
|
|
+/*
|
|
+ * tegra_wm8994.c - Tegra machine ASoC driver for boards using WM8994 codec.
|
|
+ *
|
|
+ * Author: Stephen Warren <swarren@nvidia.com>
|
|
+ * Copyright (C) 2010-2011 - NVIDIA, Inc.
|
|
+ *
|
|
+ * Based on code copyright/by:
|
|
+ *
|
|
+ * (c) 2009, 2010 Nvidia Graphics Pvt. Ltd.
|
|
+ *
|
|
+ * Copyright 2007 Wolfson Microelectronics PLC.
|
|
+ * Author: Graeme Gregory
|
|
+ * graeme.gregory@wolfsonmicro.com or linux@wolfsonmicro.com
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License
|
|
+ * version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful, but
|
|
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ * General Public License for more details.
|
|
+ *
|
|
+ * You should have received a copy of the GNU General Public License
|
|
+ * along with this program; if not, write to the Free Software
|
|
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
|
|
+ * 02110-1301 USA
|
|
+ *
|
|
+ */
|
|
+
|
|
+#include <asm/mach-types.h>
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/platform_device.h>
|
|
+#include <linux/slab.h>
|
|
+#include <linux/gpio.h>
|
|
+#include <linux/of.h>
|
|
+
|
|
+#include <sound/core.h>
|
|
+#include <sound/pcm.h>
|
|
+#include <sound/pcm_params.h>
|
|
+#include <sound/soc.h>
|
|
+
|
|
+#include "tegra_pcm.h"
|
|
+#include "tegra_asoc_utils.h"
|
|
+
|
|
+#ifdef CONFIG_ARCH_TEGRA_2x_SOC
|
|
+#include "tegra20_das.h"
|
|
+#endif
|
|
+
|
|
+#define DRV_NAME "tegra-snd-wm8994"
|
|
+
|
|
+struct tegra_wm8994 {
|
|
+ struct tegra_asoc_utils_data util_data;
|
|
+};
|
|
+
|
|
+static int tegra_wm8994_hw_params(struct snd_pcm_substream *substream,
|
|
+ struct snd_pcm_hw_params *params)
|
|
+{
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_dai *codec_dai = rtd->codec_dai;
|
|
+ struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
|
|
+ struct snd_soc_card *card = rtd->card;
|
|
+ struct tegra_wm8994 *machine = snd_soc_card_get_drvdata(card);
|
|
+ int srate, mclk, i2s_daifmt;
|
|
+ int err;
|
|
+
|
|
+ srate = params_rate(params);
|
|
+ switch (srate) {
|
|
+ case 64000:
|
|
+ case 88200:
|
|
+ case 96000:
|
|
+ mclk = 128 * srate;
|
|
+ break;
|
|
+ default:
|
|
+ mclk = 256 * srate;
|
|
+ break;
|
|
+ }
|
|
+ /* FIXME: Codec only requires >= 3MHz if OSR==0 */
|
|
+ while (mclk < 6000000)
|
|
+ mclk *= 2;
|
|
+
|
|
+ err = tegra_asoc_utils_set_rate(&machine->util_data, srate, mclk);
|
|
+ if (err < 0) {
|
|
+ if (!(machine->util_data.set_mclk % mclk))
|
|
+ mclk = machine->util_data.set_mclk;
|
|
+ else {
|
|
+ dev_err(card->dev, "Can't configure clocks\n");
|
|
+ return err;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ i2s_daifmt = SND_SOC_DAIFMT_NB_NF |
|
|
+ SND_SOC_DAIFMT_CBS_CFS;
|
|
+
|
|
+ /* Use DSP mode for mono on Tegra20 */
|
|
+ // if ((params_channels(params) != 2) &&
|
|
+ // (machine_is_ventana() || machine_is_harmony() ||
|
|
+ // machine_is_kaen() || machine_is_aebl()))
|
|
+ // i2s_daifmt |= SND_SOC_DAIFMT_DSP_A;
|
|
+ // else
|
|
+ i2s_daifmt |= SND_SOC_DAIFMT_I2S;
|
|
+
|
|
+ err = snd_soc_dai_set_fmt(codec_dai, i2s_daifmt);
|
|
+ if (err < 0) {
|
|
+ dev_err(card->dev, "codec_dai fmt not set\n");
|
|
+ return err;
|
|
+ }
|
|
+
|
|
+ err = snd_soc_dai_set_fmt(cpu_dai, i2s_daifmt);
|
|
+ if (err < 0) {
|
|
+ dev_err(card->dev, "cpu_dai fmt not set\n");
|
|
+ return err;
|
|
+ }
|
|
+ /* Need to check clk id */
|
|
+ err = snd_soc_dai_set_sysclk(codec_dai, 1, mclk,
|
|
+ SND_SOC_CLOCK_IN);
|
|
+ if (err < 0) {
|
|
+ dev_err(card->dev, "codec_dai clock not set\n");
|
|
+ return err;
|
|
+ }
|
|
+
|
|
+#ifdef CONFIG_ARCH_TEGRA_2x_SOC
|
|
+ err = tegra20_das_connect_dac_to_dap(TEGRA20_DAS_DAP_SEL_DAC1,
|
|
+ TEGRA20_DAS_DAP_ID_1);
|
|
+ if (err < 0) {
|
|
+ dev_err(card->dev, "failed to set dap-dac path\n");
|
|
+ return err;
|
|
+ }
|
|
+
|
|
+ err = tegra20_das_connect_dap_to_dac(TEGRA20_DAS_DAP_ID_1,
|
|
+ TEGRA20_DAS_DAP_SEL_DAC1);
|
|
+ if (err < 0) {
|
|
+ dev_err(card->dev, "failed to set dac-dap path\n");
|
|
+ return err;
|
|
+ }
|
|
+#endif
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int tegra_bt_sco_hw_params(struct snd_pcm_substream *substream,
|
|
+ struct snd_pcm_hw_params *params)
|
|
+{
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
|
|
+ struct snd_soc_card *card = rtd->card;
|
|
+ struct tegra_wm8994 *machine = snd_soc_card_get_drvdata(card);
|
|
+ int srate, mclk, min_mclk;
|
|
+ int err;
|
|
+
|
|
+ srate = params_rate(params);
|
|
+ switch (srate) {
|
|
+ case 11025:
|
|
+ case 22050:
|
|
+ case 44100:
|
|
+ case 88200:
|
|
+ mclk = 11289600;
|
|
+ break;
|
|
+ case 8000:
|
|
+ case 16000:
|
|
+ case 32000:
|
|
+ case 48000:
|
|
+ case 64000:
|
|
+ case 96000:
|
|
+ mclk = 12288000;
|
|
+ break;
|
|
+ default:
|
|
+ return -EINVAL;
|
|
+ }
|
|
+ min_mclk = 64 * srate;
|
|
+
|
|
+ err = tegra_asoc_utils_set_rate(&machine->util_data, srate, mclk);
|
|
+ if (err < 0) {
|
|
+ if (!(machine->util_data.set_mclk % min_mclk))
|
|
+ mclk = machine->util_data.set_mclk;
|
|
+ else {
|
|
+ dev_err(card->dev, "Can't configure clocks\n");
|
|
+ return err;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ err = snd_soc_dai_set_fmt(cpu_dai,
|
|
+ SND_SOC_DAIFMT_DSP_A |
|
|
+ SND_SOC_DAIFMT_NB_NF |
|
|
+ SND_SOC_DAIFMT_CBS_CFS);
|
|
+ if (err < 0) {
|
|
+ dev_err(card->dev, "cpu_dai fmt not set\n");
|
|
+ return err;
|
|
+ }
|
|
+
|
|
+#ifdef CONFIG_ARCH_TEGRA_2x_SOC
|
|
+ err = tegra20_das_connect_dac_to_dap(TEGRA20_DAS_DAP_SEL_DAC2,
|
|
+ TEGRA20_DAS_DAP_ID_4);
|
|
+ if (err < 0) {
|
|
+ dev_err(card->dev, "failed to set dac-dap path\n");
|
|
+ return err;
|
|
+ }
|
|
+
|
|
+ err = tegra20_das_connect_dap_to_dac(TEGRA20_DAS_DAP_ID_4,
|
|
+ TEGRA20_DAS_DAP_SEL_DAC2);
|
|
+ if (err < 0) {
|
|
+ dev_err(card->dev, "failed to set dac-dap path\n");
|
|
+ return err;
|
|
+ }
|
|
+#endif
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int tegra_spdif_hw_params(struct snd_pcm_substream *substream,
|
|
+ struct snd_pcm_hw_params *params)
|
|
+{
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_card *card = rtd->card;
|
|
+ struct tegra_wm8994 *machine = snd_soc_card_get_drvdata(card);
|
|
+ int srate, mclk, min_mclk;
|
|
+ int err;
|
|
+
|
|
+ srate = params_rate(params);
|
|
+ switch (srate) {
|
|
+ case 11025:
|
|
+ case 22050:
|
|
+ case 44100:
|
|
+ case 88200:
|
|
+ mclk = 11289600;
|
|
+ break;
|
|
+ case 8000:
|
|
+ case 16000:
|
|
+ case 32000:
|
|
+ case 48000:
|
|
+ case 64000:
|
|
+ case 96000:
|
|
+ mclk = 12288000;
|
|
+ break;
|
|
+ default:
|
|
+ return -EINVAL;
|
|
+ }
|
|
+ min_mclk = 128 * srate;
|
|
+
|
|
+ err = tegra_asoc_utils_set_rate(&machine->util_data, srate, mclk);
|
|
+ if (err < 0) {
|
|
+ if (!(machine->util_data.set_mclk % min_mclk))
|
|
+ mclk = machine->util_data.set_mclk;
|
|
+ else {
|
|
+ dev_err(card->dev, "Can't configure clocks\n");
|
|
+ return err;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int tegra_hw_free(struct snd_pcm_substream *substream)
|
|
+{
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static struct snd_soc_ops tegra_wm8994_ops = {
|
|
+ .hw_params = tegra_wm8994_hw_params,
|
|
+ .hw_free = tegra_hw_free,
|
|
+};
|
|
+
|
|
+static int tegra_wm8994_init(struct snd_soc_pcm_runtime *rtd)
|
|
+{
|
|
+ pr_info("%s\n", __func__);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int tegra_wm8994_remove(struct snd_soc_card *card)
|
|
+{
|
|
+ pr_info("%s\n", __func__);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static struct snd_soc_dai_link tegra_wm8994_dai[] = {
|
|
+ {
|
|
+ .name = "WM8994",
|
|
+ .stream_name = "WM8994 PCM",
|
|
+ .codec_dai_name = "wm8994-aif1",
|
|
+ .init = tegra_wm8994_init,
|
|
+
|
|
+ // .codec_name = "WM8994 I2C Codec.8-001b",
|
|
+ // .platform_name = "tegra-pcm-audio",
|
|
+ // .cpu_dai_name = "tegra20-i2s.0",
|
|
+ // .codec_dai_name = "WM8994 PAIFRX",
|
|
+ .ops = &tegra_wm8994_ops,
|
|
+ },
|
|
+/*
|
|
+ {
|
|
+ .name = "SPDIF",
|
|
+ .stream_name = "SPDIF PCM",
|
|
+ .codec_name = "spdif-dit.0",
|
|
+ .platform_name = "tegra-pcm-audio",
|
|
+ .cpu_dai_name = "tegra20-spdif",
|
|
+ .codec_dai_name = "dit-hifi",
|
|
+ .ops = &tegra_spdif_ops,
|
|
+ },
|
|
+*/
|
|
+/*
|
|
+ {
|
|
+ .name = "BT-SCO",
|
|
+ .stream_name = "BT SCO PCM",
|
|
+ .codec_name = "spdif-dit.1",
|
|
+ .platform_name = "tegra-pcm-audio",
|
|
+ .cpu_dai_name = "tegra20-i2s.1",
|
|
+ .codec_dai_name = "dit-hifi",
|
|
+ .ops = &tegra_wm8994_bt_sco_ops,
|
|
+ },
|
|
+*/
|
|
+};
|
|
+
|
|
+static struct snd_soc_card snd_soc_tegra_wm8994 = {
|
|
+ .name = "tegra-wm8994",
|
|
+ .dai_link = tegra_wm8994_dai,
|
|
+ .num_links = ARRAY_SIZE(tegra_wm8994_dai),
|
|
+ .remove = tegra_wm8994_remove,
|
|
+};
|
|
+
|
|
+static int tegra_wm8994_driver_probe(struct platform_device *pdev)
|
|
+{
|
|
+ struct device_node *np = pdev->dev.of_node;
|
|
+ struct snd_soc_card *card = &snd_soc_tegra_wm8994;
|
|
+ struct tegra_wm8994 *machine;
|
|
+ int ret;
|
|
+
|
|
+ pr_info("%s\n", __func__);
|
|
+
|
|
+ if (!pdev->dev.platform_data && !pdev->dev.of_node) {
|
|
+ dev_err(&pdev->dev, "No platform data supplied\n");
|
|
+ return -EINVAL;
|
|
+ }
|
|
+
|
|
+ machine = devm_kzalloc(&pdev->dev, sizeof(struct tegra_wm8994),
|
|
+ GFP_KERNEL);
|
|
+ if (!machine) {
|
|
+ dev_err(&pdev->dev, "Can't allocate tegra_wm8994 struct\n");
|
|
+ ret = -ENOMEM;
|
|
+ goto err;
|
|
+ }
|
|
+
|
|
+ card->dev = &pdev->dev;
|
|
+ platform_set_drvdata(pdev, card);
|
|
+ snd_soc_card_set_drvdata(card, machine);
|
|
+
|
|
+ // Parse device tree nodes
|
|
+
|
|
+ // ...
|
|
+
|
|
+ ret = snd_soc_of_parse_card_name(card, "nvidia,model");
|
|
+ if (ret)
|
|
+ goto err;
|
|
+
|
|
+
|
|
+ tegra_wm8994_dai[0].codec_of_node = of_parse_phandle(np,
|
|
+ "nvidia,audio-codec", 0);
|
|
+ if (!tegra_wm8994_dai[0].codec_of_node) {
|
|
+ dev_err(&pdev->dev,
|
|
+ "Property 'nvidia,audio-codec' missing or invalid\n");
|
|
+ ret = -EINVAL;
|
|
+ goto err;
|
|
+ }
|
|
+
|
|
+ tegra_wm8994_dai[0].cpu_of_node = of_parse_phandle(np,
|
|
+ "nvidia,i2s-controller", 0);
|
|
+ if (!tegra_wm8994_dai[0].cpu_of_node) {
|
|
+ dev_err(&pdev->dev,
|
|
+ "Property 'nvidia,i2s-controller' missing or invalid\n");
|
|
+ ret = -EINVAL;
|
|
+ goto err;
|
|
+ }
|
|
+
|
|
+ tegra_wm8994_dai[0].platform_of_node = tegra_wm8994_dai[0].cpu_of_node;
|
|
+/*
|
|
+ tegra_wm8994_dai[1].codec_of_node = of_parse_phandle(np,
|
|
+ "nvidia,spdif-codec", 0);
|
|
+ if (!tegra_wm8994_dai[1].codec_of_node) {
|
|
+ dev_err(&pdev->dev,
|
|
+ "Property 'nvidia,spdif-codec' missing or invalid\n");
|
|
+ ret = -EINVAL;
|
|
+ goto err;
|
|
+ }
|
|
+
|
|
+ tegra_wm8994_dai[1].cpu_of_node = of_parse_phandle(np,
|
|
+ "nvidia,spdif-controller", 0);
|
|
+ if (!tegra_wm8994_dai[1].cpu_of_node) {
|
|
+ dev_err(&pdev->dev,
|
|
+ "Property 'nvidia,spdif-controller' missing or invalid\n");
|
|
+ ret = -EINVAL;
|
|
+ goto err;
|
|
+ }
|
|
+
|
|
+ tegra_wm8994_dai[1].platform_of_node = tegra_wm8994_dai[1].cpu_of_node;
|
|
+*/
|
|
+
|
|
+ ret = tegra_asoc_utils_init(&machine->util_data, &pdev->dev);
|
|
+ if (ret) {
|
|
+ dev_err(&pdev->dev, "tegra_asoc_utils_init failed (%d)\n",
|
|
+ ret);
|
|
+ goto err;
|
|
+ }
|
|
+
|
|
+ ret = snd_soc_register_card(card);
|
|
+ if (ret) {
|
|
+ dev_err(&pdev->dev, "snd_soc_register_card failed (%d)\n",
|
|
+ ret);
|
|
+ goto err_fini_utils;
|
|
+ }
|
|
+
|
|
+ pr_info("%s: probed\n", __func__);
|
|
+
|
|
+
|
|
+ return 0;
|
|
+
|
|
+err_fini_utils:
|
|
+ tegra_asoc_utils_fini(&machine->util_data);
|
|
+err:
|
|
+ return ret;
|
|
+}
|
|
+
|
|
+static int tegra_wm8994_driver_remove(struct platform_device *pdev)
|
|
+{
|
|
+ struct snd_soc_card *card = platform_get_drvdata(pdev);
|
|
+ struct tegra_wm8994 *machine = snd_soc_card_get_drvdata(card);
|
|
+ snd_soc_unregister_card(card);
|
|
+
|
|
+ tegra_asoc_utils_fini(&machine->util_data);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static const struct of_device_id tegra_wm8994_of_match[] = {
|
|
+ { .compatible = "nvidia,tegra-audio-wm8994", },
|
|
+ {},
|
|
+};
|
|
+
|
|
+static struct platform_driver tegra_wm8994_driver = {
|
|
+ .driver = {
|
|
+ .name = DRV_NAME,
|
|
+ .owner = THIS_MODULE,
|
|
+ .pm = &snd_soc_pm_ops,
|
|
+ .of_match_table = tegra_wm8994_of_match,
|
|
+ },
|
|
+ .probe = tegra_wm8994_driver_probe,
|
|
+ .remove = tegra_wm8994_driver_remove,
|
|
+};
|
|
+
|
|
+module_platform_driver(tegra_wm8994_driver);
|
|
+
|
|
+MODULE_AUTHOR("Stephen Warren <swarren@nvidia.com>");
|
|
+MODULE_DESCRIPTION("Tegra+WM8994 machine ASoC driver");
|
|
+MODULE_LICENSE("GPL");
|
|
+MODULE_ALIAS("platform:" DRV_NAME);
|
|
+MODULE_DEVICE_TABLE(of, tegra_wm8994_of_match);
|
|
--
|
|
2.22.0
|
|
|