925b78ae16
* Fix hardcoded `armhf` in pmb/aportgen/binutils.py * Generate aports: `binutils-aarch64`, `musl-aarch64`, `gcc-aarch64` * Distccd: Remember the cross-compiler architecture (currently armhf or aarch64), that the current distccd is running as, and restart distccd with the correct architecture, in case a different arch is needed than what it is currently running as. (Depending on the cross-compiler arch, the PATH variable gets adjusted before starting distccd) * Testcases: add aport generation for aarch64, add cross-compiling to aarch64 * pmb/parse/arch.py: Add aarch64 to the mapping
35 lines
1.6 KiB
Diff
35 lines
1.6 KiB
Diff
--- gcc-6.1.0/libjava/Makefile.am
|
|
+++ gcc-6.1.0/libjava/Makefile.am
|
|
@@ -488,10 +488,14 @@
|
|
nat_files = $(nat_source_files:.cc=.lo)
|
|
xlib_nat_files = $(xlib_nat_source_files:.cc=.lo)
|
|
|
|
+libgcj_la_CPPFLAGS = \
|
|
+ $(AM_CPPFLAGS) \
|
|
+ $(LIBSTDCXX_RAW_CXX_CXXFLAGS)
|
|
+
|
|
# Include THREADLIBS here to ensure that the correct version of
|
|
# certain linuxthread functions get linked:
|
|
## The mysterious backslash in the grep pattern is consumed by make.
|
|
-libgcj_la_LDFLAGS = -rpath $(toolexeclibdir) $(THREADLDFLAGS) $(extra_ldflags) $(THREADLIBS) \
|
|
+libgcj_la_LDFLAGS = $(LIBSTDCXX_RAW_CXX_LDFLAGS) -rpath $(toolexeclibdir) $(THREADLDFLAGS) $(extra_ldflags) $(THREADLIBS) \
|
|
$(LIBLTDL) $(SYS_ZLIBS) $(LIBJAVA_LDFLAGS_NOUNDEF) \
|
|
-version-info `grep -v '^\#' $(srcdir)/libtool-version` \
|
|
$(LIBGCJ_LD_SYMBOLIC_FUNCTIONS) $(LIBGCJ_LD_EXPORT_ALL)
|
|
--- gcc-6.1.0/libjava/Makefile.in
|
|
+++ gcc-6.1.0/libjava/Makefile.in
|
|
@@ -1103,9 +1103,13 @@
|
|
nat_files = $(nat_source_files:.cc=.lo)
|
|
xlib_nat_files = $(xlib_nat_source_files:.cc=.lo)
|
|
|
|
+libgcj_la_CPPFLAGS = \
|
|
+ $(AM_CPPFLAGS) \
|
|
+ $(LIBSTDCXX_RAW_CXX_CXXFLAGS)
|
|
+
|
|
# Include THREADLIBS here to ensure that the correct version of
|
|
# certain linuxthread functions get linked:
|
|
-libgcj_la_LDFLAGS = -rpath $(toolexeclibdir) $(THREADLDFLAGS) $(extra_ldflags) $(THREADLIBS) \
|
|
+libgcj_la_LDFLAGS = $(LIBSTDCXX_RAW_CXX_LDFLAGS) -rpath $(toolexeclibdir) $(THREADLDFLAGS) $(extra_ldflags) $(THREADLIBS) \
|
|
$(LIBLTDL) $(SYS_ZLIBS) $(LIBJAVA_LDFLAGS_NOUNDEF) \
|
|
-version-info `grep -v '^\#' $(srcdir)/libtool-version` \
|
|
$(LIBGCJ_LD_SYMBOLIC_FUNCTIONS) $(LIBGCJ_LD_EXPORT_ALL)
|