356e7ecb77
This switch has happened in the Alpine repos quite a while ago and most of the pmOS packages were using it already too, so let's switch over the last ones as well. This also cleans up the APKBUILDs where necessary
26 lines
946 B
Diff
26 lines
946 B
Diff
Since the package build happens in the pmaports git repo, this check doesn't give the correct result and we should disable it.
|
|
|
|
This is not an upstreamable fix as it just removes the check rather than replacing it with something more proper.
|
|
|
|
diff --git a/libuuu/gen_ver.sh b/libuuu/gen_ver.sh
|
|
index d4e8c1ba..8f416322 100755
|
|
--- a/libuuu/gen_ver.sh
|
|
+++ b/libuuu/gen_ver.sh
|
|
@@ -13,10 +13,10 @@ else
|
|
fi
|
|
|
|
# Test if we are in a repo
|
|
-if [ "$(git rev-parse --is-inside-work-tree 2>/dev/null)" = "true" ];
|
|
-then
|
|
- #echo "In a repo"
|
|
- # Get the version of the last commit of the repo
|
|
- version=`git describe --tags --long`
|
|
- echo "#define GIT_VERSION \"lib$version\"" > $file_to_write
|
|
-fi
|
|
+#if [ "$(git rev-parse --is-inside-work-tree 2>/dev/null)" = "true" ];
|
|
+#then
|
|
+# #echo "In a repo"
|
|
+# # Get the version of the last commit of the repo
|
|
+# version=`git describe --tags --long`
|
|
+# echo "#define GIT_VERSION \"lib$version\"" > $file_to_write
|
|
+#fi
|