pmaports/luna/luna-sysmgr-ipc-messages/mkpkgconfig.patch
Alex Roth 196d555092 Merge Luna work into master (#945)
Contains everything from #940, except on top of master now.
Also added a postmarketos-ui-luna package to be a meta-
package for all of the Luna work.

Every component included here builds & runs, but isn't
functional without a handful more packages.
2017-11-29 23:29:26 +00:00

50 lines
1.6 KiB
Diff

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8bfa9e5..e9f63ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,11 +18,13 @@
cmake_minimum_required(VERSION 2.8.7)
-project(luna-sysmgr-ipc-messages NONE)
+project(LunaSysMgrIpcMessages NONE)
include(webOS/webOS)
webos_modules_init(1 0 0 QUALIFIER RC2)
webos_component(2 0 0)
+webos_build_pkgconfig()
+
# install headers in /usr/include/sysmgr-ipc
install(DIRECTORY include/public/messages/ DESTINATION ${WEBOS_INSTALL_INCLUDEDIR}/sysmgr-ipc)
diff --git a/files/pkgconfig/LunaSysMgrIpcMessages.pc.in b/files/pkgconfig/LunaSysMgrIpcMessages.pc.in
new file mode 100644
index 0000000..315d51b
--- /dev/null
+++ b/files/pkgconfig/LunaSysMgrIpcMessages.pc.in
@@ -0,0 +1,25 @@
+# @@@LICENSE
+#
+# Copyright (c) 2012-2013 LG Electronics, Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# LICENSE@@@
+
+libdir=@WEBOS_INSTALL_LIBDIR@
+includedir=@WEBOS_INSTALL_INCLUDEDIR@/sysmgr-ipc
+
+Name: luna-sysmgr-ipc-messages
+Description: @WEBOS_PROJECT_SUMMARY@
+Version: @WEBOS_COMPONENT_VERSION@
+Cflags: -I${includedir}