56f1e0c10f
Skipping CI, because it would probably not finish building all of them. Major breakage incoming. Details discussed here: <https://gitlab.com/postmarketOS/pmaports/issues/103>
194 lines
6.9 KiB
Diff
194 lines
6.9 KiB
Diff
From 48c670d2678e0323d88eb72205e039f393cabe05 Mon Sep 17 00:00:00 2001
|
|
From: Khem Raj <raj.khem@gmail.com>
|
|
Date: Fri, 29 Mar 2013 08:59:00 +0400
|
|
Subject: [PATCH 03/39] gcc: poison-system-directories
|
|
|
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
|
|
Upstream-Status: Inappropriate [distribution: codesourcery]
|
|
---
|
|
gcc/common.opt | 4 ++++
|
|
gcc/config.in | 6 ++++++
|
|
gcc/configure | 16 ++++++++++++++++
|
|
gcc/configure.ac | 10 ++++++++++
|
|
gcc/doc/invoke.texi | 9 +++++++++
|
|
gcc/gcc.c | 2 ++
|
|
gcc/incpath.c | 19 +++++++++++++++++++
|
|
7 files changed, 66 insertions(+)
|
|
|
|
diff --git a/gcc/common.opt b/gcc/common.opt
|
|
index d6ef85928f3..7b29efe3882 100644
|
|
--- a/gcc/common.opt
|
|
+++ b/gcc/common.opt
|
|
@@ -679,6 +679,10 @@ Wreturn-local-addr
|
|
Common Var(warn_return_local_addr) Init(1) Warning
|
|
Warn about returning a pointer/reference to a local or temporary variable.
|
|
|
|
+Wpoison-system-directories
|
|
+Common Var(flag_poison_system_directories) Init(1) Warning
|
|
+Warn for -I and -L options using system directories if cross compiling
|
|
+
|
|
Wshadow
|
|
Common Var(warn_shadow) Warning
|
|
Warn when one variable shadows another. Same as -Wshadow=global.
|
|
diff --git a/gcc/config.in b/gcc/config.in
|
|
index 5bccb408016..1c784a8276b 100644
|
|
--- a/gcc/config.in
|
|
+++ b/gcc/config.in
|
|
@@ -194,6 +194,12 @@
|
|
#endif
|
|
|
|
|
|
+/* Define to warn for use of native system header directories */
|
|
+#ifndef USED_FOR_TARGET
|
|
+#undef ENABLE_POISON_SYSTEM_DIRECTORIES
|
|
+#endif
|
|
+
|
|
+
|
|
/* Define if you want all operations on RTL (the basic data structure of the
|
|
optimizer and back end) to be checked for dynamic type safety at runtime.
|
|
This is quite expensive. */
|
|
diff --git a/gcc/configure b/gcc/configure
|
|
index 5c345ce0fd7..cafd05fd150 100755
|
|
--- a/gcc/configure
|
|
+++ b/gcc/configure
|
|
@@ -953,6 +953,7 @@ with_system_zlib
|
|
enable_maintainer_mode
|
|
enable_link_mutex
|
|
enable_version_specific_runtime_libs
|
|
+enable_poison_system_directories
|
|
enable_plugin
|
|
enable_host_shared
|
|
enable_libquadmath_support
|
|
@@ -1696,6 +1697,8 @@ Optional Features:
|
|
--enable-version-specific-runtime-libs
|
|
specify that runtime libraries should be installed
|
|
in a compiler-specific directory
|
|
+ --enable-poison-system-directories
|
|
+ warn for use of native system header directories
|
|
--enable-plugin enable plugin support
|
|
--enable-host-shared build host code as shared libraries
|
|
--disable-libquadmath-support
|
|
@@ -29715,6 +29718,19 @@ if test "${enable_version_specific_runtime_libs+set}" = set; then :
|
|
fi
|
|
|
|
|
|
+# Check whether --enable-poison-system-directories was given.
|
|
+if test "${enable_poison_system_directories+set}" = set; then :
|
|
+ enableval=$enable_poison_system_directories;
|
|
+else
|
|
+ enable_poison_system_directories=no
|
|
+fi
|
|
+
|
|
+if test "x${enable_poison_system_directories}" = "xyes"; then
|
|
+
|
|
+$as_echo "#define ENABLE_POISON_SYSTEM_DIRECTORIES 1" >>confdefs.h
|
|
+
|
|
+fi
|
|
+
|
|
# Substitute configuration variables
|
|
|
|
|
|
diff --git a/gcc/configure.ac b/gcc/configure.ac
|
|
index 65dbf1f2f80..dd5b38195ce 100644
|
|
--- a/gcc/configure.ac
|
|
+++ b/gcc/configure.ac
|
|
@@ -6341,6 +6341,16 @@ AC_ARG_ENABLE(version-specific-runtime-libs,
|
|
[specify that runtime libraries should be
|
|
installed in a compiler-specific directory])])
|
|
|
|
+AC_ARG_ENABLE([poison-system-directories],
|
|
+ AS_HELP_STRING([--enable-poison-system-directories],
|
|
+ [warn for use of native system header directories]),,
|
|
+ [enable_poison_system_directories=no])
|
|
+if test "x${enable_poison_system_directories}" = "xyes"; then
|
|
+ AC_DEFINE([ENABLE_POISON_SYSTEM_DIRECTORIES],
|
|
+ [1],
|
|
+ [Define to warn for use of native system header directories])
|
|
+fi
|
|
+
|
|
# Substitute configuration variables
|
|
AC_SUBST(subdirs)
|
|
AC_SUBST(srcdir)
|
|
diff --git a/gcc/doc/invoke.texi b/gcc/doc/invoke.texi
|
|
index 255149fcfb8..cb71b60fe3c 100644
|
|
--- a/gcc/doc/invoke.texi
|
|
+++ b/gcc/doc/invoke.texi
|
|
@@ -303,6 +303,7 @@ Objective-C and Objective-C++ Dialects}.
|
|
-Wpacked -Wpacked-bitfield-compat -Wpacked-not-aligned -Wpadded @gol
|
|
-Wparentheses -Wno-pedantic-ms-format @gol
|
|
-Wplacement-new -Wplacement-new=@var{n} @gol
|
|
+-Wno-poison-system-directories @gol
|
|
-Wpointer-arith -Wpointer-compare -Wno-pointer-to-int-cast @gol
|
|
-Wno-pragmas -Wredundant-decls -Wrestrict -Wno-return-local-addr @gol
|
|
-Wreturn-type -Wsequence-point -Wshadow -Wno-shadow-ivar @gol
|
|
@@ -5712,6 +5713,14 @@ made up of data only and thus requires no special treatment. But, for
|
|
most targets, it is made up of code and thus requires the stack to be
|
|
made executable in order for the program to work properly.
|
|
|
|
+@item -Wno-poison-system-directories
|
|
+@opindex Wno-poison-system-directories
|
|
+Do not warn for @option{-I} or @option{-L} options using system
|
|
+directories such as @file{/usr/include} when cross compiling. This
|
|
+option is intended for use in chroot environments when such
|
|
+directories contain the correct headers and libraries for the target
|
|
+system rather than the host.
|
|
+
|
|
@item -Wfloat-equal
|
|
@opindex Wfloat-equal
|
|
@opindex Wno-float-equal
|
|
diff --git a/gcc/gcc.c b/gcc/gcc.c
|
|
index a716f708259..02b3cd39fc2 100644
|
|
--- a/gcc/gcc.c
|
|
+++ b/gcc/gcc.c
|
|
@@ -1037,6 +1037,8 @@ proper position among the other output files. */
|
|
"%{fuse-ld=*:-fuse-ld=%*} " LINK_COMPRESS_DEBUG_SPEC \
|
|
"%X %{o*} %{e*} %{N} %{n} %{r}\
|
|
%{s} %{t} %{u*} %{z} %{Z} %{!nostdlib:%{!nostartfiles:%S}} \
|
|
+ %{Wno-poison-system-directories:--no-poison-system-directories} \
|
|
+ %{Werror=poison-system-directories:--error-poison-system-directories} \
|
|
%{static|no-pie|static-pie:} %{L*} %(mfwrap) %(link_libgcc) " \
|
|
VTABLE_VERIFICATION_SPEC " " SANITIZER_EARLY_SPEC " %o " CHKP_SPEC " \
|
|
%{fopenacc|fopenmp|%:gt(%{ftree-parallelize-loops=*:%*} 1):\
|
|
diff --git a/gcc/incpath.c b/gcc/incpath.c
|
|
index b11c6a57939..e3b7a21966f 100644
|
|
--- a/gcc/incpath.c
|
|
+++ b/gcc/incpath.c
|
|
@@ -26,6 +26,7 @@
|
|
#include "intl.h"
|
|
#include "incpath.h"
|
|
#include "cppdefault.h"
|
|
+#include "diagnostic-core.h"
|
|
|
|
/* Microsoft Windows does not natively support inodes.
|
|
VMS has non-numeric inodes. */
|
|
@@ -393,6 +394,26 @@ merge_include_chains (const char *sysroot, cpp_reader *pfile, int verbose)
|
|
}
|
|
fprintf (stderr, _("End of search list.\n"));
|
|
}
|
|
+
|
|
+#ifdef ENABLE_POISON_SYSTEM_DIRECTORIES
|
|
+ if (flag_poison_system_directories)
|
|
+ {
|
|
+ struct cpp_dir *p;
|
|
+
|
|
+ for (p = heads[INC_QUOTE]; p; p = p->next)
|
|
+ {
|
|
+ if ((!strncmp (p->name, "/usr/include", 12))
|
|
+ || (!strncmp (p->name, "/usr/local/include", 18))
|
|
+ || (!strncmp (p->name, "/usr/X11R6/include", 18))
|
|
+ || (!strncmp (p->name, "/sw/include", 11))
|
|
+ || (!strncmp (p->name, "/opt/include", 12)))
|
|
+ warning (OPT_Wpoison_system_directories,
|
|
+ "include location \"%s\" is unsafe for "
|
|
+ "cross-compilation",
|
|
+ p->name);
|
|
+ }
|
|
+ }
|
|
+#endif
|
|
}
|
|
|
|
/* Use given -I paths for #include "..." but not #include <...>, and
|
|
--
|
|
2.17.0
|
|
|