pmaports/device/linux-htc-protou/no-hardcoded-CROSS_COMPILE.patch
Ingo Feinerer 28f0e5d4e1
htc-protou: new device (HTC Desire X) (!588)
Changes in the kernel defconfig:
- disable ANDROID_PARANOID_NETWORK (removes network restrictions)
- enable CONFIG_USB_G_ANDROID and CONFIG_DIAG_CHAR (for USB networking)
- enable DEVTMPFS (needed for udev -> touch support in weston)
- enable FB_MSM_DEFAULT_DEPTH_RGB565 (for 16-bit support to avoid red
  screen)
- enable SYSVIPC (so busybox' syslogd can log to a ringbuffer in the
  kernel)
- enable VT (for virtual terminal over USB)

[ci:skip-build]: already built successfully in CI
2019-08-31 21:19:16 +02:00

12 lines
372 B
Diff

diff -Naur a/Makefile b/Makefile
--- a/Makefile 2013-11-29 03:09:36.000000000 +0100
+++ b/Makefile 2019-05-25 23:21:31.810636014 +0200
@@ -194,8 +194,6 @@
export KBUILD_BUILDHOST := $(SUBARCH)
ARCH ?= $(SUBARCH)
CROSS_COMPILE ?= $(CONFIG_CROSS_COMPILE:"%"=%)
-ARCH := arm
-CROSS_COMPILE := arm-eabi-
# Architecture as present in compile.h
UTS_MACHINE := $(ARCH)