fb23669e29
* Added linux-postmarketos-allwinner kernel * Added copy of alpines u-boot package with pine-a64lts support * Changed postmarketos-mkinitfs to add the plain .dtb file to the boot partition
207 lines
6.8 KiB
Diff
207 lines
6.8 KiB
Diff
diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
|
|
index 6fe93a8..d67914f 100644
|
|
--- a/arch/arm/dts/Makefile
|
|
+++ b/arch/arm/dts/Makefile
|
|
@@ -379,7 +379,8 @@ dtb-$(CONFIG_MACH_SUN50I) += \
|
|
sun50i-a64-olinuxino.dtb \
|
|
sun50i-a64-orangepi-win.dtb \
|
|
sun50i-a64-pine64-plus.dtb \
|
|
- sun50i-a64-pine64.dtb
|
|
+ sun50i-a64-pine64.dtb \
|
|
+ sun50i-a64-sopine-baseboard.dtb
|
|
dtb-$(CONFIG_MACH_SUN9I) += \
|
|
sun9i-a80-optimus.dtb \
|
|
sun9i-a80-cubieboard4.dtb \
|
|
diff --git a/configs/sopine_baseboard_defconfig b/configs/sopine_baseboard_defconfig
|
|
index 05436a1..c79c111 100644
|
|
--- a/configs/sopine_baseboard_defconfig
|
|
+++ b/configs/sopine_baseboard_defconfig
|
|
@@ -10,7 +10,7 @@ CONFIG_DRAM_ODT_EN=y
|
|
CONFIG_MMC0_CD_PIN=""
|
|
CONFIG_MMC_SUNXI_SLOT_EXTRA=2
|
|
CONFIG_SPL_SPI_SUNXI=y
|
|
-CONFIG_DEFAULT_DEVICE_TREE="sun50i-a64-pine64-plus"
|
|
+CONFIG_DEFAULT_DEVICE_TREE="sun50i-a64-sopine-baseboard"
|
|
# CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
|
|
# CONFIG_CMD_FLASH is not set
|
|
# CONFIG_SPL_DOS_PARTITION is not set
|
|
diff --git a/arch/arm/dts/sun50i-a64-sopine-baseboard.dts b/arch/arm/dts/sun50i-a64-sopine-baseboard.dts
|
|
new file mode 100644
|
|
index 0000000..42c0f10
|
|
--- /dev/null
|
|
+++ b/arch/arm/dts/sun50i-a64-sopine-baseboard.dts
|
|
@@ -0,0 +1,102 @@
|
|
+/*
|
|
+ * Copyright (c) 2017 Icenowy Zheng <icenowy@aosc.xyz>
|
|
+ *
|
|
+ * Based on sun50i-a64-pine64.dts, which is:
|
|
+ * Copyright (c) 2016 ARM Ltd.
|
|
+ *
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
+ * licensing only applies to this file, and not this project as a
|
|
+ * whole.
|
|
+ *
|
|
+ * a) This library is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
+ * License, or (at your option) any later version.
|
|
+ *
|
|
+ * This library is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * Or, alternatively,
|
|
+ *
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
+ * obtaining a copy of this software and associated documentation
|
|
+ * files (the "Software"), to deal in the Software without
|
|
+ * restriction, including without limitation the rights to use,
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
+ * Software is furnished to do so, subject to the following
|
|
+ * conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "sun50i-a64-sopine.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "SoPine with baseboard";
|
|
+ compatible = "pine64,sopine-baseboard", "pine64,sopine",
|
|
+ "allwinner,sun50i-a64";
|
|
+
|
|
+ aliases {
|
|
+ serial0 = &uart0;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial0:115200n8";
|
|
+ };
|
|
+
|
|
+ reg_vcc1v8: vcc1v8 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "vcc1v8";
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ehci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ehci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mmc2 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&mmc2_pins>;
|
|
+ vmmc-supply = <®_vcc3v3>;
|
|
+ vqmmc-supply = <®_vcc1v8>;
|
|
+ bus-width = <8>;
|
|
+ non-removable;
|
|
+ cap-mmc-hw-reset;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ohci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ohci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart0_pins_a>;
|
|
+ status = "okay";
|
|
+};
|
|
diff --git a/arch/arm/dts/sun50i-a64-sopine.dtsi b/arch/arm/dts/sun50i-a64-sopine.dtsi
|
|
new file mode 100644
|
|
index 0000000..475518b
|
|
--- /dev/null
|
|
+++ b/arch/arm/dts/sun50i-a64-sopine.dtsi
|
|
@@ -0,0 +1,65 @@
|
|
+/*
|
|
+ * Copyright (c) 2017 Icenowy Zheng <icenowy@aosc.xyz>
|
|
+ *
|
|
+ * Based on sun50i-a64-pine64.dts, which is:
|
|
+ * Copyright (c) 2016 ARM Ltd.
|
|
+ *
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
+ * licensing only applies to this file, and not this project as a
|
|
+ * whole.
|
|
+ *
|
|
+ * a) This library is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
+ * License, or (at your option) any later version.
|
|
+ *
|
|
+ * This library is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * Or, alternatively,
|
|
+ *
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
+ * obtaining a copy of this software and associated documentation
|
|
+ * files (the "Software"), to deal in the Software without
|
|
+ * restriction, including without limitation the rights to use,
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
+ * Software is furnished to do so, subject to the following
|
|
+ * conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+
|
|
+#include "sun50i-a64.dtsi"
|
|
+
|
|
+/ {
|
|
+ reg_vcc3v3: vcc3v3 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "vcc3v3";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&mmc0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&mmc0_pins>;
|
|
+ vmmc-supply = <®_vcc3v3>;
|
|
+ non-removable;
|
|
+ disable-wp;
|
|
+ bus-width = <4>;
|
|
+ status = "okay";
|
|
+};
|
|
|