pmaports/device/testing/linux-xiaomi-whyred/fix-vl53l0-includes.patch
javabird25 790cda59be
xiaomi-whyred: new device (Xiaomi Redmi Note 5 Pro) (!1088)
Started porting pmOS to Xiaomi Redmi Note 5 Pro (whyred).
What works so far:
 - Booting
 - SSH over USB
 - SD card detection (haven't tried flashing to internal storage because
   i'm afraid of bricking the device due to anti-rollback)
 - Vibration and LEDs
 - Screen
 - Hardware buttons
 - Touchscreen

Untested:
 - WiFi
 - Camera
 - Audio
 - Bluetooth
 - GPS
 - Calls, SMS, Cellular network
2020-03-23 10:15:48 +01:00

11 lines
889 B
Diff

diff --git a/drivers/input/misc/vl53L0/Makefile b/drivers/input/misc/vl53L0/Makefile
index f105e1c3..d207f030 100644
--- a/drivers/input/misc/vl53L0/Makefile
+++ b/drivers/input/misc/vl53L0/Makefile
@@ -16,5 +16,6 @@ ccflags-y += -Idrivers/media/platform/msm/camera_v2/sensor/io
ccflags-y += -Idrivers/media/platform/msm/camera_v2
ccflags-y += -Idrivers/media/platform/msm/camera_v2/common
ccflags-y += -Idrivers/media/platform/msm/camera_v2/sensor/cci
+ccflags-y += -Idrivers/input/misc/vl53L0
obj-$(CONFIG_INPUT_STMVL53L0) += stmvl53l0.o
stmvl53l0-objs := stmvl53l0_module.o stmvl53l0_module-i2c.o stmvl53l0_module-cci.o src/vl53l0_api_calibration.o src/vl53l0_api_core.o src/vl53l0_api_histogram.o src/vl53l0_api_ranging.o src/vl53l0_api_strings.o src/vl53l0_api.o src/vl53l0_platform.o src/vl53l0_i2c_platform.o src/vl53l0_port_i2c.o src/vl53l010_api.o src/vl53l010_tuning.o