56f1e0c10f
Skipping CI, because it would probably not finish building all of them. Major breakage incoming. Details discussed here: <https://gitlab.com/postmarketOS/pmaports/issues/103>
58 lines
2.7 KiB
Diff
58 lines
2.7 KiB
Diff
# DP: Use --push-state/--pop-state for gold as well when linking libtsan.
|
|
|
|
Index: b/gcc/gcc.c
|
|
===================================================================
|
|
--- a/gcc/gcc.c
|
|
+++ b/gcc/gcc.c
|
|
@@ -693,10 +693,10 @@ proper position among the other output f
|
|
#define LIBASAN_SPEC STATIC_LIBASAN_LIBS
|
|
#elif defined(HAVE_LD_STATIC_DYNAMIC)
|
|
#define LIBASAN_SPEC "%{static-libasan:" LD_STATIC_OPTION "}" \
|
|
- " %{!static-libasan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " %{!static-libasan:--push-state --no-as-needed}" \
|
|
" -lasan " \
|
|
" %{static-libasan:" LD_DYNAMIC_OPTION "}" \
|
|
- " %{!static-libasan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
+ " %{!static-libasan:--pop-state}" \
|
|
STATIC_LIBASAN_LIBS
|
|
#else
|
|
#define LIBASAN_SPEC "-lasan" STATIC_LIBASAN_LIBS
|
|
@@ -714,10 +714,10 @@ proper position among the other output f
|
|
#define LIBTSAN_SPEC STATIC_LIBTSAN_LIBS
|
|
#elif defined(HAVE_LD_STATIC_DYNAMIC)
|
|
#define LIBTSAN_SPEC "%{static-libtsan:" LD_STATIC_OPTION "}" \
|
|
- " %{!static-libtsan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " %{!static-libtsan:--push-state --no-as-needed}" \
|
|
" -ltsan " \
|
|
" %{static-libtsan:" LD_DYNAMIC_OPTION "}" \
|
|
- " %{!static-libtsan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
+ " %{!static-libtsan:--pop-state}" \
|
|
STATIC_LIBTSAN_LIBS
|
|
#else
|
|
#define LIBTSAN_SPEC "-ltsan" STATIC_LIBTSAN_LIBS
|
|
@@ -735,10 +735,10 @@ proper position among the other output f
|
|
#define LIBLSAN_SPEC STATIC_LIBLSAN_LIBS
|
|
#elif defined(HAVE_LD_STATIC_DYNAMIC)
|
|
#define LIBLSAN_SPEC "%{static-liblsan:" LD_STATIC_OPTION "}" \
|
|
- " %{!static-liblsan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " %{!static-liblsan:--push-state --no-as-needed}" \
|
|
" -llsan " \
|
|
" %{static-liblsan:" LD_DYNAMIC_OPTION "}" \
|
|
- " %{!static-liblsan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
+ " %{!static-liblsan:--pop-state}" \
|
|
STATIC_LIBLSAN_LIBS
|
|
#else
|
|
#define LIBLSAN_SPEC "-llsan" STATIC_LIBLSAN_LIBS
|
|
@@ -754,10 +754,10 @@ proper position among the other output f
|
|
" %{static-libubsan|static:%:include(libsanitizer.spec)%(link_libubsan)}"
|
|
#ifdef HAVE_LD_STATIC_DYNAMIC
|
|
#define LIBUBSAN_SPEC "%{static-libubsan:" LD_STATIC_OPTION "}" \
|
|
- " %{!static-libubsan:%{!fuse-ld=gold:--push-state }--no-as-needed}" \
|
|
+ " %{!static-libubsan:--push-state --no-as-needed}" \
|
|
" -lubsan " \
|
|
" %{static-libubsan:" LD_DYNAMIC_OPTION "}" \
|
|
- " %{!static-libubsan:%{fuse-ld=gold:--as-needed;:--pop-state}}" \
|
|
+ " %{!static-libubsan:--pop-state}" \
|
|
STATIC_LIBUBSAN_LIBS
|
|
#else
|
|
#define LIBUBSAN_SPEC "-lubsan" STATIC_LIBUBSAN_LIBS
|