987d9c735d
Also remove the py-requests, as the version has been updated in Alpine. Close: #1603
65 lines
2 KiB
Diff
65 lines
2 KiB
Diff
From 68898bc82bcb0e697ed03c2405321033ba7feaf7 Mon Sep 17 00:00:00 2001
|
|
From: Paolo Bonzini <pbonzini@redhat.com>
|
|
Date: Thu, 17 May 2018 14:39:42 +0200
|
|
Subject: [PATCH] ui: add x_keymap.o to modules
|
|
|
|
x_keymap.o is common to the SDL and GTK+ modules, and it causes the
|
|
QEMU binary to link to the X11 libraries. Add it separately to the
|
|
modules to keep the main QEMU binary smaller.
|
|
|
|
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
|
|
Message-id: 1526560782-18732-1-git-send-email-pbonzini@redhat.com
|
|
|
|
[ kraxel: fix lm32 target build (milkymist-tmu2) ]
|
|
|
|
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
|
---
|
|
hw/display/Makefile.objs | 2 ++
|
|
ui/Makefile.objs | 11 +++++++----
|
|
2 files changed, 9 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/hw/display/Makefile.objs b/hw/display/Makefile.objs
|
|
index 3c7c75b94d..11321e466b 100644
|
|
--- a/hw/display/Makefile.objs
|
|
+++ b/hw/display/Makefile.objs
|
|
@@ -20,6 +20,8 @@ common-obj-$(CONFIG_MILKYMIST) += milkymist-vgafb.o
|
|
common-obj-$(CONFIG_ZAURUS) += tc6393xb.o
|
|
|
|
common-obj-$(CONFIG_MILKYMIST_TMU2) += milkymist-tmu2.o
|
|
+milkymist-tmu2.o-cflags := $(X11_CFLAGS)
|
|
+milkymist-tmu2.o-libs := $(X11_LIBS)
|
|
|
|
obj-$(CONFIG_OMAP) += omap_dss.o
|
|
obj-$(CONFIG_OMAP) += omap_lcdc.o
|
|
diff --git a/ui/Makefile.objs b/ui/Makefile.objs
|
|
index cc784346cb..00f6976c30 100644
|
|
--- a/ui/Makefile.objs
|
|
+++ b/ui/Makefile.objs
|
|
@@ -15,10 +15,6 @@ common-obj-$(CONFIG_COCOA) += cocoa.o
|
|
common-obj-$(CONFIG_VNC) += $(vnc-obj-y)
|
|
common-obj-$(call lnot,$(CONFIG_VNC)) += vnc-stubs.o
|
|
|
|
-common-obj-$(CONFIG_X11) += x_keymap.o
|
|
-x_keymap.o-cflags := $(X11_CFLAGS)
|
|
-x_keymap.o-libs := $(X11_LIBS)
|
|
-
|
|
# ui-sdl module
|
|
common-obj-$(CONFIG_SDL) += sdl.mo
|
|
ifeq ($(CONFIG_SDLABI),1.2)
|
|
@@ -46,6 +42,13 @@ gtk.mo-objs += gtk-gl-area.o
|
|
endif
|
|
endif
|
|
|
|
+ifeq ($(CONFIG_X11),y)
|
|
+sdl.mo-objs += x_keymap.o
|
|
+gtk.mo-objs += x_keymap.o
|
|
+x_keymap.o-cflags := $(X11_CFLAGS)
|
|
+x_keymap.o-libs := $(X11_LIBS)
|
|
+endif
|
|
+
|
|
common-obj-$(CONFIG_CURSES) += curses.mo
|
|
curses.mo-objs := curses.o
|
|
curses.mo-cflags := $(CURSES_CFLAGS)
|
|
--
|
|
2.17.0
|
|
|