981db6c080
Let's clean up temp and move these not-so-temporary U-Boot forks to the appropriate device subdirectory instead.
56 lines
1.6 KiB
Diff
56 lines
1.6 KiB
Diff
From 599896bc50b4532f39105ed0c40ada838227650d Mon Sep 17 00:00:00 2001
|
|
From: Samuel Holland <samuel@sholland.org>
|
|
Date: Thu, 7 May 2020 18:50:37 -0500
|
|
Subject: [PATCH 01/10] sunxi: DT: H6: update device tree files
|
|
|
|
Import updated device trees from Linux v5.9.
|
|
|
|
Signed-off-by: Samuel Holland <samuel@sholland.org>
|
|
---
|
|
arch/arm/dts/Makefile | 1 +
|
|
arch/arm/dts/sun50i-h6-pine-h64-model-b.dts | 21 +++++++++++++++++++++
|
|
2 files changed, 22 insertions(+)
|
|
create mode 100644 arch/arm/dts/sun50i-h6-pine-h64-model-b.dts
|
|
|
|
diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
|
|
index fc16a57e60..de2e4ca66b 100644
|
|
--- a/arch/arm/dts/Makefile
|
|
+++ b/arch/arm/dts/Makefile
|
|
@@ -642,6 +642,7 @@ dtb-$(CONFIG_MACH_SUN50I_H6) += \
|
|
sun50i-h6-orangepi-lite2.dtb \
|
|
sun50i-h6-orangepi-one-plus.dtb \
|
|
sun50i-h6-pine-h64.dtb \
|
|
+ sun50i-h6-pine-h64-model-b.dtb \
|
|
sun50i-h6-tanix-tx6.dtb
|
|
dtb-$(CONFIG_MACH_SUN50I_H616) += \
|
|
sun50i-h616-orangepi-zero2.dtb
|
|
diff --git a/arch/arm/dts/sun50i-h6-pine-h64-model-b.dts b/arch/arm/dts/sun50i-h6-pine-h64-model-b.dts
|
|
new file mode 100644
|
|
index 0000000000..f4c8966a64
|
|
--- /dev/null
|
|
+++ b/arch/arm/dts/sun50i-h6-pine-h64-model-b.dts
|
|
@@ -0,0 +1,21 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ or MIT)
|
|
+/*
|
|
+ * Copyright (C) 2019 Corentin LABBE <clabbe@baylibre.com>
|
|
+ */
|
|
+
|
|
+#include "sun50i-h6-pine-h64.dts"
|
|
+
|
|
+/ {
|
|
+ model = "Pine H64 model B";
|
|
+ compatible = "pine64,pine-h64-model-b", "allwinner,sun50i-h6";
|
|
+
|
|
+ /delete-node/ reg_gmac_3v3;
|
|
+};
|
|
+
|
|
+&hdmi_connector {
|
|
+ /delete-property/ ddc-en-gpios;
|
|
+};
|
|
+
|
|
+&emac {
|
|
+ phy-supply = <®_aldo2>;
|
|
+};
|
|
--
|
|
2.31.1
|
|
|