e350b00b9b
We don't want executable APKBUILDs, deviceinfo files, etc in pmaports. Remove the executable bit from those files. [ci:skip-build] [ci:skip-vercheck]
46 lines
1.5 KiB
Diff
46 lines
1.5 KiB
Diff
From bd447b61c49fc26f0299587db3e6d66da49dc529 Mon Sep 17 00:00:00 2001
|
|
From: Chen Gang <gang.chen.5i5j@gmail.com>
|
|
Date: Sun, 9 Nov 2014 13:31:11 -0800
|
|
Subject: [PATCH] Input: lifebook - use "static inline" instead of "inline" in
|
|
lifebook.h
|
|
|
|
For functions defined in header files we should use static inline rather
|
|
than inline, which breaks under the latest upstream gcc (which is really
|
|
gcc issue, but static inline is better suited regardless).
|
|
|
|
The related error (with allmodconfig under tile):
|
|
|
|
MODPOST 4002 modules
|
|
ERROR: "lifebook_detect" [drivers/input/mouse/psmouse.ko] undefined!
|
|
|
|
Signed-off-by: Chen Gang <gang.chen.5i5j@gmail.com>
|
|
Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
|
|
---
|
|
drivers/input/mouse/lifebook.h | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/drivers/input/mouse/lifebook.h b/drivers/input/mouse/lifebook.h
|
|
index 4c4326c6f504..0baf02a70a99 100644
|
|
--- a/drivers/input/mouse/lifebook.h
|
|
+++ b/drivers/input/mouse/lifebook.h
|
|
@@ -16,14 +16,14 @@ void lifebook_module_init(void);
|
|
int lifebook_detect(struct psmouse *psmouse, bool set_properties);
|
|
int lifebook_init(struct psmouse *psmouse);
|
|
#else
|
|
-inline void lifebook_module_init(void)
|
|
+static inline void lifebook_module_init(void)
|
|
{
|
|
}
|
|
-inline int lifebook_detect(struct psmouse *psmouse, bool set_properties)
|
|
+static inline int lifebook_detect(struct psmouse *psmouse, bool set_properties)
|
|
{
|
|
return -ENOSYS;
|
|
}
|
|
-inline int lifebook_init(struct psmouse *psmouse)
|
|
+static inline int lifebook_init(struct psmouse *psmouse)
|
|
{
|
|
return -ENOSYS;
|
|
}
|
|
--
|
|
2.14.1
|
|
|