pmaports/device/linux-nokia-frt/02_drvgen_mk.patch
Piotr Halama dcc2ce2438 nokia-frt: adjust to fixed upstream repo (!380)
Nokia only provides .zip files without any git history, so I had to
download the kernel git repo for 3.18.79 and then apply all downstream
changes as one singular commit to preserve at least some of the history.

My previous PC had big problems with creating patch files for symlinks
so I added some commits that should have been in patchfiles instead.
This merge request fixes that, leaving in repo just 3.18.79+downstream
patches and all my patches as patchfiles inside aports.

[ci:skip-build]: already built successfully in CI
2019-05-26 18:07:11 +00:00

17 lines
921 B
Diff

This program cannot be used as it uses glibc, it doesn't seem to break anything
diff --git a/scripts/drvgen/drvgen.mk b/scripts/drvgen/drvgen.mk
index 17f5f7b7273d..a40efd974f3f 100644
--- a/scripts/drvgen/drvgen.mk
+++ b/scripts/drvgen/drvgen.mk
@@ -92,7 +92,8 @@ $(DTB_OVERLAY_IMAGE_TAGERT) : $(PRIVATE_MULTIPLE_DTB_OVERLAY_OBJ) dtbs $(PRIVATE
@echo Singing the generated overlay dtbo.
cat $(PRIVATE_DTB_OVERLAY_OBJ) > $(PRIVATE_MULTIPLE_DTB_OVERLAY_OBJ) || (rm -f $(PRIVATE_MULTIPLE_DTB_OVERLAY_OBJ); false)
python $(PRIVATE_MULTIPLE_DTB_OVERLAY_HDR) $(PRIVATE_MULTIPLE_DTB_OVERLAY_OBJ) $(PRIVATE_MULTIPLE_DTB_OVERLAY_IMG)
- $(PRIVATE_MKIMAGE_TOOL) $(PRIVATE_MULTIPLE_DTB_OVERLAY_IMG) $(PRIVATE_MKIMAGE_CFG) > $@
+ # Not needed, requires glibc
+ #$(PRIVATE_MKIMAGE_TOOL) $(PRIVATE_MULTIPLE_DTB_OVERLAY_IMG) $(PRIVATE_MKIMAGE_CFG) > $@
.PHONY: odmdtboimage dtbs
odmdtboimage : $(DTB_OVERLAY_IMAGE_TAGERT)