4c0ec94eb4
Port based on an unofficial LineageOS port from https://www.los-legacy.de/17.1/zerofltexx, using kernel from https://github.com/Exynos7420/android_kernel_samsung_exynos7420/ What works: - Kernel boots - Display and touch input (tested with Weston) - USB networking - Wifi For now only including Wifi drivers, as I wasn't yet able to successfully test audio and camera subsystems (but I intentionally left these firmware files commented out in the APKBUILD file). [ci:skip-build]: already built successfully in CI
35 lines
1 KiB
Diff
35 lines
1 KiB
Diff
--- a/drivers/net/wireless/bcmdhd4358/dhd.h
|
|
+++ b/drivers/net/wireless/bcmdhd4358/dhd.h
|
|
@@ -1468,13 +1468,7 @@
|
|
extern int dhdpcie_set_suspend_resume(struct pci_dev *dev, bool state);
|
|
#endif /* DHD_USE_IDLECOUNT && BCMPCIE */
|
|
|
|
-#ifdef DHD_LEGACY_FILE_PATH
|
|
-#define PLATFORM_PATH "/data/"
|
|
-#elif defined(PLATFORM_SLP)
|
|
-#define PLATFORM_PATH "/opt/etc/"
|
|
-#else
|
|
-#define PLATFORM_PATH "/data/misc/conn/"
|
|
-#endif /* DHD_LEGACY_FILE_PATH */
|
|
+#define PLATFORM_PATH "/lib/firmware/postmarketos/"
|
|
|
|
/*
|
|
* Enable this macro if you want to track the calls to wake lock
|
|
--- a/drivers/net/wireless/bcmdhd4359/dhd.h
|
|
+++ b/drivers/net/wireless/bcmdhd4359/dhd.h
|
|
@@ -1830,14 +1830,8 @@
|
|
|
|
extern bool dhd_query_bus_erros(dhd_pub_t *dhdp);
|
|
|
|
-#ifdef DHD_LEGACY_FILE_PATH
|
|
-#define PLATFORM_PATH "/data/"
|
|
-#elif defined(PLATFORM_SLP)
|
|
-#define PLATFORM_PATH "/opt/etc/"
|
|
-#else
|
|
-#define PLATFORM_PATH "/data/misc/conn/"
|
|
-#endif /* DHD_LEGACY_FILE_PATH */
|
|
+#define PLATFORM_PATH "/lib/firmware/postmarketos/"
|
|
|
|
/*
|
|
* Enable this macro if you want to track the calls to wake lock
|
|
|