dcc2ce2438
Nokia only provides .zip files without any git history, so I had to download the kernel git repo for 3.18.79 and then apply all downstream changes as one singular commit to preserve at least some of the history. My previous PC had big problems with creating patch files for symlinks so I added some commits that should have been in patchfiles instead. This merge request fixes that, leaving in repo just 3.18.79+downstream patches and all my patches as patchfiles inside aports. [ci:skip-build]: already built successfully in CI
16 lines
611 B
Diff
16 lines
611 B
Diff
On some Mediatek kernel this seems to help with incorrect path "./tools/tools"
|
|
---
|
|
|
|
diff --git a/tools/scripts/Makefile.include b/tools/scripts/Makefile.include
|
|
index 8abbef164b4e..7a2f1510a630 100644
|
|
--- a/tools/scripts/Makefile.include
|
|
+++ b/tools/scripts/Makefile.include
|
|
@@ -2,7 +2,7 @@ ifneq ($(O),)
|
|
ifeq ($(origin O), command line)
|
|
dummy := $(if $(shell test -d $(O) || echo $(O)),$(error O=$(O) does not exist),)
|
|
ABSOLUTE_O := $(shell cd $(O) ; pwd)
|
|
- OUTPUT := $(ABSOLUTE_O)/$(if $(subdir),$(subdir)/)
|
|
+ OUTPUT := $(ABSOLUTE_O)/
|
|
COMMAND_O := O=$(ABSOLUTE_O)
|
|
ifeq ($(objtree),)
|
|
objtree := $(O)
|