4c0ec94eb4
Port based on an unofficial LineageOS port from https://www.los-legacy.de/17.1/zerofltexx, using kernel from https://github.com/Exynos7420/android_kernel_samsung_exynos7420/ What works: - Kernel boots - Display and touch input (tested with Weston) - USB networking - Wifi For now only including Wifi drivers, as I wasn't yet able to successfully test audio and camera subsystems (but I intentionally left these firmware files commented out in the APKBUILD file). [ci:skip-build]: already built successfully in CI
15 lines
552 B
Diff
15 lines
552 B
Diff
diff --git a/Makefile b/Makefile
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -197,11 +197,6 @@
|
|
CROSS_COMPILE ?= ../PLATFORM/prebuilts/gcc/linux-x86/aarch64/aarch64-linux-android-4.9/bin/aarch64-linux-android-
|
|
#CROSS_COMPILE ?= /opt/toolchains/aarch64-linux-android-4.9/bin/aarch64-linux-android-
|
|
|
|
-ifeq ($(shell uname -s),Linux)
|
|
- ifeq ($(shell uname -m),x86_64)
|
|
- override CROSS_COMPILE := $(srctree)/../../../prebuilts/linaro/linux-x86/aarch64/bin/aarch64-linux-gnu-
|
|
- endif
|
|
-endif
|
|
|
|
# Architecture as present in compile.h
|
|
UTS_MACHINE := $(ARCH)
|