pmaports/maemo/libhildondesktop/stop-deprecated-functions-from-breaking-compilation.patch
Grant Miller ef59cc8a30
maemo/libhildondesktop: Fix compilation (!131)
Thanks to PureTryOut for the patch

[skip ci]: the CI script will fail with the "too many packages have
changed" sanity check. ollieparanod has verified that everything builds
before merging.
2019-01-09 07:41:26 +01:00

16 lines
713 B
Diff

diff --git a/configure.ac b/configure.ac
index 3d15e48..70fec1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,9 +71,9 @@ fi
if test "x${hildon_use_instrumenting}" = "xyes"
then
- CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -Wmissing-declarations -Werror -Wno-format-extra-args -g -finstrument-functions"
+ CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -Wmissing-declarations -Wno-format-extra-args -g -finstrument-functions"
else
- CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -Wmissing-declarations -Werror -Wno-format-extra-args -DG_DISABLE_CAST_CHECKS"
+ CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -Wmissing-declarations -Wno-format-extra-args -DG_DISABLE_CAST_CHECKS"
fi
AC_SUBST(CFLAGS)