129f93ec5b
This updates google-crosshatch's downstream kernel to Lineage 17.1's version (4.9.200, shared with Lineage's Pixel 3a port). The newer kernel is needed because this device's kernel requires a matching dtbo partition. The previous kernel would fail to boot with an Android 10 dtbo partition. Two patches were removed: Android 10's bootloader no longer passes the dm or skip_initramfs boot arguments because of the new dynamic partitions (https://source.android.com/devices/tech/ota/dynamic_partitions/ab_legacy). Changes from the LineageOS kernel config: https://gist.github.com/zhuowei/89b4135ff27e88f5a3dd3e4bf3cd31ab Tested by booting to USB networking and debug-shell: I have not tested flashing full pmOS using this kernel yet. For some reason, on this kernel, when pmOS can't find system partitions during the "Trying to mount subpartitions for 10 seconds..." stage, it waits for 70 seconds instead of 10 seconds. I'm not sure why. It does go to debug-shell correctly after a minute. [ci:skip-build]: already built successfully in CI
27 lines
1 KiB
Diff
27 lines
1 KiB
Diff
From 55832681f3390b0d7868ed1156e2930672fbdd71 Mon Sep 17 00:00:00 2001
|
|
From: Zhuowei Zhang <linux@worthdoingbadly.com>
|
|
Date: Sun, 8 Mar 2020 00:41:12 -0500
|
|
Subject: [PATCH] arm64: boot: disable building DTBO images
|
|
|
|
postmarketOS doesn't flash the DTBO partition, and doesn't package
|
|
the dtbo tools yet. Just don't build them.
|
|
---
|
|
arch/arm64/boot/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/arch/arm64/boot/Makefile b/arch/arm64/boot/Makefile
|
|
index 87c5d9dd76c1..ef52f38965d5 100644
|
|
--- a/arch/arm64/boot/Makefile
|
|
+++ b/arch/arm64/boot/Makefile
|
|
@@ -70,7 +70,7 @@ $(obj)/Image.lz4-dtb: $(obj)/Image.lz4 $(DTB_OBJS) FORCE
|
|
ifeq ($(CONFIG_BUILD_ARM64_DT_OVERLAY),y)
|
|
ifeq ($(CONFIG_BOARD_B1C1),y)
|
|
$(obj)/dtbo.img: $(obj)/dts/dtboimg.cfg $(DTBO_OBJS) FORCE
|
|
- $(call if_changed,mkdtimg,4096) # align dtbo.img to 4kB
|
|
+ # $(call if_changed,mkdtimg,4096) # align dtbo.img to 4kB
|
|
else
|
|
$(obj)/dtbo.img: $(obj)/dts/dtboimg-sdm670.cfg $(DTBO_OBJS) FORCE
|
|
$(call if_changed,mkdtimg,4096) # align dtbo.img to 4kB
|
|
--
|
|
2.20.1
|
|
|