afd26b3b97
This reverts commit d56a2facfb
and changes the main/gcc6 pkgrel to 9999, so it will always be higher
than Alpine's version.
39 lines
1.3 KiB
Diff
39 lines
1.3 KiB
Diff
Ensure that msgfmt doesn't encounter problems during gcc bootstrapping.
|
|
|
|
Solves error messages like the following:
|
|
|
|
msgfmt: /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6)
|
|
|
|
The libgcc_s.so used during build doesn't satisfy the needs of the
|
|
libstdc++.so that msgfmt is linked against. On the other hand, msgfmt
|
|
is used as a stand-alone application here, and what library it uses
|
|
behind the scenes is of no concern to the gcc build process.
|
|
Therefore, simply invoking it "as usual", i.e. without any special
|
|
library path, will make it work as expected here.
|
|
|
|
2011-09-19 Martin von Gagern
|
|
|
|
References:
|
|
https://bugs.gentoo.org/372377
|
|
https://bugs.gentoo.org/295480
|
|
|
|
--- gcc-4.1.2.orig/libstdc++-v3/po/Makefile.am
|
|
+++ gcc-4.1.2/libstdc++-v3/po/Makefile.am
|
|
@@ -39,6 +39,7 @@ MSGFMT = msgfmt
|
|
EXTRA_DIST = string_literals.cc POTFILES.in $(PACKAGE).pot $(LOCALE_IN)
|
|
|
|
.po.mo:
|
|
+ env --unset=LD_LIBRARY_PATH \
|
|
$(MSGFMT) -o $@ $<
|
|
|
|
all-local: all-local-$(USE_NLS)
|
|
--- gcc-4.1.2.orig/libstdc++-v3/po/Makefile.in
|
|
+++ gcc-4.1.2/libstdc++-v3/po/Makefile.in
|
|
@@ -419,6 +419,7 @@ uninstall-am: uninstall-info-am
|
|
|
|
|
|
.po.mo:
|
|
+ env --unset=LD_LIBRARY_PATH \
|
|
$(MSGFMT) -o $@ $<
|
|
|
|
all-local: all-local-$(USE_NLS)
|