925b78ae16
* Fix hardcoded `armhf` in pmb/aportgen/binutils.py * Generate aports: `binutils-aarch64`, `musl-aarch64`, `gcc-aarch64` * Distccd: Remember the cross-compiler architecture (currently armhf or aarch64), that the current distccd is running as, and restart distccd with the correct architecture, in case a different arch is needed than what it is currently running as. (Depending on the cross-compiler arch, the PATH variable gets adjusted before starting distccd) * Testcases: add aport generation for aarch64, add cross-compiling to aarch64 * pmb/parse/arch.py: Add aarch64 to the mapping
10 lines
317 B
Diff
10 lines
317 B
Diff
--- a/libiberty/Makefile.in
|
|
+++ b/libiberty/Makefile.in
|
|
@@ -246,6 +246,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS)
|
|
$(AR) $(AR_FLAGS) $(TARGETLIB) \
|
|
$(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS); \
|
|
$(RANLIB) $(TARGETLIB); \
|
|
+ cp $(TARGETLIB) ../ ; \
|
|
cd ..; \
|
|
else true; fi
|
|
|