pmaports/temp/networkmanager/fix-ppc64le-build.patch
Oliver Smith 271aba5d0f
temp: build networkmanager for armhf, armv7
Due to the following dependency chain, it is currently not available
in Alpine for armhf and armv7. This breaks postmarketos-base.

postmarketos-base -> networkmanager -> polkit -> mozjs60

This can be reverted, when networkmanager is back for arm{hf,v7} in
Alpine. The mozjs60 arm fix is from here:
https://github.com/alpinelinux/aports/pull/7561

Related: #244
2019-05-05 17:54:58 +02:00

12 lines
323 B
Diff

diff --git a/libnm/meson.build b/libnm/meson.build
index 4b3df97..31c6fa6 100644
--- a/libnm/meson.build
+++ b/libnm/meson.build
@@ -162,6 +162,7 @@ libnm = shared_library(
libnm_core_dep,
uuid_dep,
libnm_systemd_shared_no_logging_dep,
+ libnmdbus_dep,
],
c_args: cflags,
link_with: libnm_utils,