646e0b50df
- 0003-dts-pinetab-add-missing-bma223-ohci1.patch
The original patch added a node for BMA223 and a node for ohci1.
The former is already present in upstream, so the new patch
0003-dts-pinetab-add-missing-ohci1.patch only adds the latter.
- 0004-arm64-dts-allwinner-Add-bluetooth-node-to-the-PineTa.patch
The patch is now present in upstream so it has been removed.
However it's worth noting that upstream's node has the wake GPIOs
reversed from the original patch. The original patch added:
device-wake-gpios = <&r_pio 0 6 GPIO_ACTIVE_LOW>; /* PL6 */
host-wake-gpios = <&r_pio 0 5 GPIO_ACTIVE_HIGH>; /* PL5 */
... while upstream has:
device-wake-gpios = <&r_pio 0 5 GPIO_ACTIVE_LOW>; /* PL5 */
host-wake-gpios = <&r_pio 0 6 GPIO_ACTIVE_HIGH>; /* PL6 */
This has not been tested on a PineTab.
- 0005-dts-pinetab-make-audio-routing-consistent-with-pinep.patch
The first hunk of the patch is in upstream and has been removed.
- 0013-Revert-usb-quirks-Add-USB_QUIRK_RESET-for-Quectel-EG25G-Modem.patch
This patch reverted upstream commit that was present until v6.7
( f9e3e7ea4e
)
but is not present in v6.8, so the patch has been removed.
- 0014-usb-serial-option-add-reset-resume-callback-for-WWAN.patch
The patch is now present in upstream so it has been removed.
135 lines
3.2 KiB
Diff
135 lines
3.2 KiB
Diff
From 190989087e4a6a775b3cdab450301b7c9ef75f5c Mon Sep 17 00:00:00 2001
|
|
From: JuniorJPDJ <git@juniorjpdj.pl>
|
|
Date: Tue, 23 Mar 2021 12:29:37 +0100
|
|
Subject: [PATCH] ARM: dts: sun6i: Add GoClever Orion 70L tablet
|
|
|
|
---
|
|
arch/arm/boot/dts/allwinner/Makefile | 1 +
|
|
.../sun6i-a31s-goclever-gcta741l.dts | 103 ++++++++++++++++++
|
|
2 files changed, 104 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/allwinner/sun6i-a31s-goclever-gcta741l.dts
|
|
|
|
diff --git a/arch/arm/boot/dts/allwinner/Makefile b/arch/arm/boot/dts/allwinner/Makefile
|
|
index 7c7fb94d2153..097614b95ff2 100644
|
|
--- a/arch/arm/boot/dts/allwinner/Makefile
|
|
+++ b/arch/arm/boot/dts/allwinner/Makefile
|
|
@@ -110,6 +110,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
|
|
sun6i-a31-mele-a1000g-quad.dtb \
|
|
sun6i-a31s-colorfly-e708-q1.dtb \
|
|
sun6i-a31s-cs908.dtb \
|
|
+ sun6i-a31s-goclever-gcta741l.dtb \
|
|
sun6i-a31s-inet-q972.dtb \
|
|
sun6i-a31s-primo81.dtb \
|
|
sun6i-a31s-sina31s.dtb \
|
|
diff --git a/arch/arm/boot/dts/allwinner/sun6i-a31s-goclever-gcta741l.dts b/arch/arm/boot/dts/allwinner/sun6i-a31s-goclever-gcta741l.dts
|
|
new file mode 100644
|
|
index 000000000000..4fcba20ffe48
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/allwinner/sun6i-a31s-goclever-gcta741l.dts
|
|
@@ -0,0 +1,103 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ OR X11)
|
|
+// Copyright 2021 Jacek Pruciak <linux@juniorjpdj.pl>
|
|
+
|
|
+/dts-v1/;
|
|
+#include "sun6i-a31s.dtsi"
|
|
+#include "sun6i-reference-design-tablet.dtsi"
|
|
+//#include <dt-bindings/pwm/pwm.h>
|
|
+
|
|
+/ {
|
|
+ model = "GoClever Orion 70L";
|
|
+ compatible = "goclever,gcta741l", "allwinner,sun6i-a31s";
|
|
+
|
|
+ panel {
|
|
+ compatible = "hannstar,tqtm070cb501";
|
|
+ power-supply = <®_dc1sw>;
|
|
+ //backlight = <&backlight>;
|
|
+
|
|
+ port {
|
|
+ panel_input: endpoint {
|
|
+ remote-endpoint = <&tcon0_out_lcd>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ // PWM not supported by sun6i at the moment
|
|
+ //backlight {
|
|
+ // compatible = "pwm-backlight";
|
|
+ // pwms = <&pwm 0 50000 PWM_POLARITY_INVERTED>;
|
|
+ // brightness-levels = <0 10 20 30 40 50 60 70 80 90 100>;
|
|
+ // default-brightness-level = <8>;
|
|
+ // enable-gpios = <&pio 0 25 GPIO_ACTIVE_HIGH>; /* PA25 */
|
|
+ //};
|
|
+};
|
|
+
|
|
+&usb_otg {
|
|
+ dr_mode = "otg";
|
|
+};
|
|
+
|
|
+&battery_power_supply {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&lradc {
|
|
+ vref-supply = <®_aldo3>;
|
|
+ status = "okay";
|
|
+
|
|
+ button-1000 {
|
|
+ label = "Home";
|
|
+ linux,code = <KEY_HOMEPAGE>;
|
|
+ channel = <0>;
|
|
+ voltage = <1000000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&i2c2 {
|
|
+ status = "okay";
|
|
+
|
|
+ accelerometer@4c {
|
|
+ compatible = "fsl,mma7660";
|
|
+ reg = <0x4c>;
|
|
+ interrupt-parent = <&pio>;
|
|
+ interrupts = <0 9 IRQ_TYPE_LEVEL_HIGH>; /* PA9 */
|
|
+
|
|
+ mount-matrix = "0", "1", "0",
|
|
+ "1", "0", "0",
|
|
+ "0", "0", "1";
|
|
+ };
|
|
+};
|
|
+
|
|
+&tcon0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&lcd0_rgb888_pins>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&tcon0_out {
|
|
+ tcon0_out_lcd: endpoint@0 {
|
|
+ reg = <0>;
|
|
+ remote-endpoint = <&panel_input>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&de {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&simplefb_lcd {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&codec {
|
|
+ // This still doesn't work
|
|
+ allwinner,audio-routing =
|
|
+ /* sink, source */
|
|
+ "Headphone", "HP",
|
|
+ "Speaker", "LINEOUT",
|
|
+ "MIC1", "Mic",
|
|
+ "MIC2", "Headset Mic",
|
|
+ "Mic", "MBIAS",
|
|
+ "Headset Mic", "HBIAS";
|
|
+ allwinner,pa-gpios = <&r_pio 0 4 GPIO_ACTIVE_HIGH>; /* PL4 */
|
|
+ status = "okay";
|
|
+};
|
|
--
|
|
2.44.0
|
|
|