pmaports/device/testing/linux-samsung-goyavewifi/no-hardcoded-CROSS_COMPILE.patch
choc 2b7036dd54
testing/samsung-goyavewifi: new device (MR 3377)
xorg, ssh, touchscreen, battery works
[ci:skip-build]: already built successfully in CI
2022-12-01 09:50:53 +01:00

14 lines
508 B
Diff

diff --git a/Makefile b/Makefile
index b7291f3d..78b30681 100755
--- a/Makefile
+++ b/Makefile
@@ -193,7 +193,7 @@ SUBARCH := $(shell uname -m | sed -e s/i.86/x86/ -e s/x86_64/x86/ \
# Default value for CROSS_COMPILE is not to prefix executables
# Note: Some architectures assign CROSS_COMPILE in their arch/*/Makefile
ARCH =arm
-CROSS_COMPILE =/opt/toolchains/arm-eabi-4.7/bin/arm-eabi-
+CROSS_COMPILE ?= $(CONFIG_CROSS_COMPILE:"%"=%)
# Architecture as present in compile.h
UTS_MACHINE := $(ARCH)