5cef6135da
Copy Alpine's gcc6 aport to temp. They don't have it built for aarch64 and armhf at the moment. Due to dependency checks, this means we can't build the kernels that need gcc6, even when cross compiling with gcc6-armhf etc. See #138 for details.
41 lines
1.6 KiB
Diff
41 lines
1.6 KiB
Diff
When cross compiling a target gcc, target flags may be used on the host
|
|
|
|
Configure identifies a number of warning flags (WARN_CFLAGS and
|
|
WARN_CXXFLAGS) from the $CC value. The cross compiler may be different
|
|
from the host compiler and may not support the same set of flags. This
|
|
leads to problems such as:
|
|
|
|
cc1plus: error: unrecognized command line option "-Wno-narrowing"
|
|
cc1plus: error: unrecognized command line option "-Wno-overlength-strings"
|
|
|
|
Work around this problem by removing the warning flags from the
|
|
BUILD_CXXFLAGS value, in a way similar to the BUILD_CFLAGS.
|
|
|
|
Upstream-Status: Pending
|
|
|
|
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
|
|
|
|
Index: gcc-4.8.0/gcc/configure
|
|
===================================================================
|
|
--- gcc-4.8.0.orig/gcc/configure
|
|
+++ gcc-4.8.0/gcc/configure
|
|
@@ -11720,6 +10581,7 @@ STMP_FIXINC=stmp-fixinc
|
|
if test x$build != x$host || test "x$coverage_flags" != x
|
|
then
|
|
BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
|
|
+ BUILD_CXXFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
|
|
BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)'
|
|
fi
|
|
|
|
Index: gcc-4.8.0/gcc/configure.ac
|
|
===================================================================
|
|
--- gcc-4.8.0.orig/gcc/configure.ac
|
|
+++ gcc-4.8.0/gcc/configure.ac
|
|
@@ -1901,6 +1901,7 @@ STMP_FIXINC=stmp-fixinc AC_SUBST(STMP_F
|
|
if test x$build != x$host || test "x$coverage_flags" != x
|
|
then
|
|
BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
|
|
+ BUILD_CXXFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
|
|
BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)'
|
|
fi
|
|
|