737cff798a
Based on the last version from Alpine, but installed to /usr/gcc6 and with pretty much everything disabled except for the C compiler. We can probably throw out a lot of patches, and make the APKBUILD much smaller. But let's focus on making it possible to compile old kernels again first. There's still a lot to do for that, see #103.
10 lines
342 B
Diff
10 lines
342 B
Diff
--- gcc-4.8.1/Makefile.in.orig
|
|
+++ gcc-4.8.1/Makefile.in
|
|
@@ -169,6 +169,7 @@
|
|
# built for the build system to override those in BASE_FLAGS_TO_PASSS.
|
|
EXTRA_BUILD_FLAGS = \
|
|
CFLAGS="$(CFLAGS_FOR_BUILD)" \
|
|
+ CXXFLAGS="$(CXXFLAGS_FOR_BUILD)" \
|
|
LDFLAGS="$(LDFLAGS_FOR_BUILD)"
|
|
|
|
# This is the list of directories to built for the host system.
|