8c2a95dbe2
* Mir starts up and is able to display system settings * x86_64 only for now, because at least ubuntu-app-test did not build on aarch64 Based on PureTryOut's work. Getting it to this stage was a huge effort (as it shows in the package count: 111(!)). See the merge request for details. [skip ci]: this won't finish in CI; ollieparanoid made sure that everything builds for x86_64.
37 lines
1 KiB
Diff
37 lines
1 KiB
Diff
From 1289c8754848b1b95d89037aea6ddf3bde3534db Mon Sep 17 00:00:00 2001
|
|
From: Luca Weiss <luca@z3ntu.xyz>
|
|
Date: Sat, 12 Jan 2019 14:12:54 +0100
|
|
Subject: [PATCH 1/3] Use proper GTest
|
|
|
|
---
|
|
CMakeLists.txt | 2 --
|
|
tests/CMakeLists.txt | 2 +-
|
|
2 files changed, 1 insertion(+), 3 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index d5076b4..e6e5485 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -84,6 +84,4 @@ add_subdirectory(examples/)
|
|
|
|
#### Enable tests
|
|
include(CTest)
|
|
-set(GTEST_ROOT /usr/src/gtest)
|
|
add_subdirectory(tests/)
|
|
-add_subdirectory(${GTEST_ROOT} ${CMAKE_CURRENT_BINARY_DIR}/gtest)
|
|
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
|
index 2b7204f..659510c 100644
|
|
--- a/tests/CMakeLists.txt
|
|
+++ b/tests/CMakeLists.txt
|
|
@@ -1,7 +1,7 @@
|
|
find_package(PkgConfig REQUIRED)
|
|
pkg_check_modules(PROCESS_CPP process-cpp REQUIRED)
|
|
|
|
-include_directories(${GTEST_ROOT}/src)
|
|
+find_package(GTest)
|
|
include_directories(${PROCESS_CPP_INCLUDE_DIRS})
|
|
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++11")
|
|
--
|
|
2.20.1
|
|
|