pmaports/device/testing/linux-postmarketos-qcom-msm8994/0001-arm64-dts-qcom-msm8992-lg-bullhead-Place-LG-Bullhead.patch
Petr Vorel 891a4cb5a1
linux-postmarketos-qcom-msm8994: upgrade to 5.17.2 (MR 3073)
patches added are (not all, just some) fixes and feature enhancements
for msm8992 and msm8994 from qcom mainline maintainer tree [1] for v5.18
and v5.19.

Changes:
* update deviceinfo_dtb_mainline for device-huawei-angler and
  device-lg-bullhead.
* add sdhc1 support for device-huawei-angler

[1] https://git.kernel.org/pub/scm/linux/kernel/git/qcom/linux.git

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>

[ci:skip-build] Already built successfully in CI in MR
2022-05-01 12:26:18 +03:00

80 lines
3.2 KiB
Diff

From 383094fa8188a695d655bbe9eccdb469b17eb350 Mon Sep 17 00:00:00 2001
From: Jean THOMAS <virgule@jeanthomas.me>
Date: Thu, 2 Dec 2021 00:18:31 +0100
Subject: [PATCH 1/8] arm64: dts: qcom: msm8992-lg-bullhead: Place LG Bullhead
generic code into a DTSI file
This patch puts the generic code common across all hardware revisions
into a DTSI file.
It also prefixes the DTS filename with the vendor name, to follow the
naming convention used by other DTS files.
[ cherry-picked from 3f99518c6f6520ad0fd14d862d54ee12f16156b4 ]
Signed-off-by: Jean THOMAS <virgule@jeanthomas.me>
Reviewed-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Bjorn Andersson <bjorn.andersson@linaro.org>
Link: https://lore.kernel.org/r/20211201231832.188634-1-virgule@jeanthomas.me
Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
---
arch/arm64/boot/dts/qcom/Makefile | 2 +-
.../boot/dts/qcom/msm8992-lg-bullhead-rev-101.dts | 14 ++++++++++++++
...llhead-rev-101.dts => msm8992-lg-bullhead.dtsi} | 2 --
3 files changed, 15 insertions(+), 3 deletions(-)
create mode 100644 arch/arm64/boot/dts/qcom/msm8992-lg-bullhead-rev-101.dts
rename arch/arm64/boot/dts/qcom/{msm8992-bullhead-rev-101.dts => msm8992-lg-bullhead.dtsi} (98%)
diff --git a/arch/arm64/boot/dts/qcom/Makefile b/arch/arm64/boot/dts/qcom/Makefile
index f7232052d286..ee8e81f1c449 100644
--- a/arch/arm64/boot/dts/qcom/Makefile
+++ b/arch/arm64/boot/dts/qcom/Makefile
@@ -18,7 +18,7 @@ dtb-$(CONFIG_ARCH_QCOM) += msm8916-samsung-a5u-eur.dtb
dtb-$(CONFIG_ARCH_QCOM) += msm8916-samsung-j5.dtb
dtb-$(CONFIG_ARCH_QCOM) += msm8916-samsung-serranove.dtb
dtb-$(CONFIG_ARCH_QCOM) += msm8916-wingtech-wt88047.dtb
-dtb-$(CONFIG_ARCH_QCOM) += msm8992-bullhead-rev-101.dtb
+dtb-$(CONFIG_ARCH_QCOM) += msm8992-lg-bullhead-rev-101.dtb
dtb-$(CONFIG_ARCH_QCOM) += msm8992-msft-lumia-octagon-talkman.dtb
dtb-$(CONFIG_ARCH_QCOM) += msm8992-xiaomi-libra.dtb
dtb-$(CONFIG_ARCH_QCOM) += msm8994-angler-rev-101.dtb
diff --git a/arch/arm64/boot/dts/qcom/msm8992-lg-bullhead-rev-101.dts b/arch/arm64/boot/dts/qcom/msm8992-lg-bullhead-rev-101.dts
new file mode 100644
index 000000000000..e6a5ebd30e2f
--- /dev/null
+++ b/arch/arm64/boot/dts/qcom/msm8992-lg-bullhead-rev-101.dts
@@ -0,0 +1,14 @@
+// SPDX-License-Identifier: GPL-2.0-only
+/* Copyright (c) Jean Thomas <virgule@jeanthomas.me>
+ */
+
+/dts-v1/;
+
+#include "msm8992-lg-bullhead.dtsi"
+
+/ {
+ model = "LG Nexus 5X rev 1.01";
+
+ /* required for bootloader to select correct board */
+ qcom,board-id = <0xb64 0>;
+};
diff --git a/arch/arm64/boot/dts/qcom/msm8992-bullhead-rev-101.dts b/arch/arm64/boot/dts/qcom/msm8992-lg-bullhead.dtsi
similarity index 98%
rename from arch/arm64/boot/dts/qcom/msm8992-bullhead-rev-101.dts
rename to arch/arm64/boot/dts/qcom/msm8992-lg-bullhead.dtsi
index 4da6c44bf532..3b0cc85d6674 100644
--- a/arch/arm64/boot/dts/qcom/msm8992-bullhead-rev-101.dts
+++ b/arch/arm64/boot/dts/qcom/msm8992-lg-bullhead.dtsi
@@ -18,9 +18,7 @@ / {
compatible = "lg,bullhead", "qcom,msm8992";
chassis-type = "handset";
- /* required for bootloader to select correct board */
qcom,msm-id = <251 0>, <252 0>;
- qcom,board-id = <0xb64 0>;
qcom,pmic-id = <0x10009 0x1000A 0x0 0x0>;
/* Bullhead firmware doesn't support PSCI */
--
2.35.1