646e0b50df
- 0003-dts-pinetab-add-missing-bma223-ohci1.patch
The original patch added a node for BMA223 and a node for ohci1.
The former is already present in upstream, so the new patch
0003-dts-pinetab-add-missing-ohci1.patch only adds the latter.
- 0004-arm64-dts-allwinner-Add-bluetooth-node-to-the-PineTa.patch
The patch is now present in upstream so it has been removed.
However it's worth noting that upstream's node has the wake GPIOs
reversed from the original patch. The original patch added:
device-wake-gpios = <&r_pio 0 6 GPIO_ACTIVE_LOW>; /* PL6 */
host-wake-gpios = <&r_pio 0 5 GPIO_ACTIVE_HIGH>; /* PL5 */
... while upstream has:
device-wake-gpios = <&r_pio 0 5 GPIO_ACTIVE_LOW>; /* PL5 */
host-wake-gpios = <&r_pio 0 6 GPIO_ACTIVE_HIGH>; /* PL6 */
This has not been tested on a PineTab.
- 0005-dts-pinetab-make-audio-routing-consistent-with-pinep.patch
The first hunk of the patch is in upstream and has been removed.
- 0013-Revert-usb-quirks-Add-USB_QUIRK_RESET-for-Quectel-EG25G-Modem.patch
This patch reverted upstream commit that was present until v6.7
( f9e3e7ea4e
)
but is not present in v6.8, so the patch has been removed.
- 0014-usb-serial-option-add-reset-resume-callback-for-WWAN.patch
The patch is now present in upstream so it has been removed.
61 lines
2 KiB
Diff
61 lines
2 KiB
Diff
From b8eb420ae85c75a211f1970f6dcb7f732e19138d Mon Sep 17 00:00:00 2001
|
|
From: Martijn Braam <martijn@brixit.nl>
|
|
Date: Tue, 20 Oct 2020 14:42:01 +0200
|
|
Subject: [PATCH] dts: add pinetab-dev (old display panel)
|
|
|
|
---
|
|
arch/arm64/boot/dts/allwinner/Makefile | 1 +
|
|
.../dts/allwinner/sun50i-a64-pinetab-dev.dts | 29 +++++++++++++++++++
|
|
2 files changed, 30 insertions(+)
|
|
create mode 100644 arch/arm64/boot/dts/allwinner/sun50i-a64-pinetab-dev.dts
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/Makefile b/arch/arm64/boot/dts/allwinner/Makefile
|
|
index d83ff6eaf752..61a84673519a 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/Makefile
|
|
+++ b/arch/arm64/boot/dts/allwinner/Makefile
|
|
@@ -17,6 +17,7 @@ dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinephone-1.2.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinephone-1.2b.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinetab.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinetab-early-adopter.dtb
|
|
+dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-pinetab-dev.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-sopine-baseboard.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a64-teres-i.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun50i-a100-allwinner-perf1.dtb
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-pinetab-dev.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-pinetab-dev.dts
|
|
new file mode 100644
|
|
index 000000000000..1e287f2fb9f3
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-pinetab-dev.dts
|
|
@@ -0,0 +1,29 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
+/*
|
|
+ * Copyright (C) 2019 Icenowy Zheng <icenowy@aosc.xyz>
|
|
+ *
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "sun50i-a64-pinetab.dts"
|
|
+
|
|
+/ {
|
|
+ model = "PineTab";
|
|
+ compatible = "pine64,pinetab", "allwinner,sun50i-a64";
|
|
+};
|
|
+
|
|
+&dsi {
|
|
+ vcc-dsi-supply = <®_dldo1>;
|
|
+ status = "okay";
|
|
+
|
|
+ panel@0 {
|
|
+ compatible = "feixin,k101-im2ba02";
|
|
+ reg = <0>;
|
|
+ avdd-supply = <®_dc1sw>;
|
|
+ dvdd-supply = <®_dc1sw>;
|
|
+ cvdd-supply = <®_ldo_io1>;
|
|
+ reset-gpios = <&pio 3 24 GPIO_ACTIVE_HIGH>; /* PD24 */
|
|
+ backlight = <&backlight>;
|
|
+ };
|
|
+};
|
|
--
|
|
2.44.0
|
|
|