17dae7d98c
Make it possible to build old kernels with gcc4 for armv7 and aarch64. The packages have been generated with (as usually): $ pmbootstrap aportgen gcc4-aarch64 gcc4-armv7 [ci:skip-build]: I have tested that this builds locally. Fixes #193.
190 lines
7.1 KiB
Diff
190 lines
7.1 KiB
Diff
From 160397ef3c3331099af028f1b8d3e085b07d88ad Mon Sep 17 00:00:00 2001
|
|
From: Khem Raj <raj.khem@gmail.com>
|
|
Date: Fri, 29 Mar 2013 08:59:00 +0400
|
|
Subject: [PATCH 16/35] gcc: poison-system-directories
|
|
|
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
|
|
Upstream-Status: Inappropriate [distribution: codesourcery]
|
|
---
|
|
gcc/Makefile.in | 2 +-
|
|
gcc/common.opt | 4 ++++
|
|
gcc/config.in | 6 ++++++
|
|
gcc/configure | 20 ++++++++++++++++++--
|
|
gcc/configure.ac | 10 ++++++++++
|
|
gcc/doc/invoke.texi | 9 +++++++++
|
|
gcc/gcc.c | 2 ++
|
|
gcc/incpath.c | 19 +++++++++++++++++++
|
|
8 files changed, 69 insertions(+), 3 deletions(-)
|
|
|
|
Index: gcc-4.9-20140316/gcc/common.opt
|
|
===================================================================
|
|
--- gcc-4.9-20140316.orig/gcc/common.opt
|
|
+++ gcc-4.9-20140316/gcc/common.opt
|
|
@@ -603,6 +603,10 @@ Wpedantic
|
|
Common Var(pedantic) Warning
|
|
Issue warnings needed for strict compliance to the standard
|
|
|
|
+Wpoison-system-directories
|
|
+Common Var(flag_poison_system_directories) Init(1) Warning
|
|
+Warn for -I and -L options using system directories if cross compiling
|
|
+
|
|
Wshadow
|
|
Common Var(warn_shadow) Warning
|
|
Warn when one local variable shadows another
|
|
Index: gcc-4.9-20140316/gcc/config.in
|
|
===================================================================
|
|
--- gcc-4.9-20140316.orig/gcc/config.in
|
|
+++ gcc-4.9-20140316/gcc/config.in
|
|
@@ -138,6 +138,12 @@
|
|
#endif
|
|
|
|
|
|
+/* Define to warn for use of native system header directories */
|
|
+#ifndef USED_FOR_TARGET
|
|
+#undef ENABLE_POISON_SYSTEM_DIRECTORIES
|
|
+#endif
|
|
+
|
|
+
|
|
/* Define if you want all operations on RTL (the basic data structure of the
|
|
optimizer and back end) to be checked for dynamic type safety at runtime.
|
|
This is quite expensive. */
|
|
Index: gcc-4.9-20140316/gcc/configure
|
|
===================================================================
|
|
--- gcc-4.9-20140316.orig/gcc/configure
|
|
+++ gcc-4.9-20140316/gcc/configure
|
|
@@ -928,6 +928,7 @@ with_system_zlib
|
|
enable_maintainer_mode
|
|
enable_link_mutex
|
|
enable_version_specific_runtime_libs
|
|
+enable_poison_system_directories
|
|
enable_plugin
|
|
enable_host_shared
|
|
enable_libquadmath_support
|
|
@@ -1648,6 +1649,8 @@ Optional Features:
|
|
--enable-version-specific-runtime-libs
|
|
specify that runtime libraries should be installed
|
|
in a compiler-specific directory
|
|
+ --enable-poison-system-directories
|
|
+ warn for use of native system header directories
|
|
--enable-plugin enable plugin support
|
|
--enable-host-shared build host code as shared libraries
|
|
--disable-libquadmath-support
|
|
@@ -27702,6 +27705,19 @@ if test "${enable_version_specific_runti
|
|
fi
|
|
|
|
|
|
+# Check whether --enable-poison-system-directories was given.
|
|
+if test "${enable_poison_system_directories+set}" = set; then :
|
|
+ enableval=$enable_poison_system_directories;
|
|
+else
|
|
+ enable_poison_system_directories=no
|
|
+fi
|
|
+
|
|
+if test "x${enable_poison_system_directories}" = "xyes"; then
|
|
+
|
|
+$as_echo "#define ENABLE_POISON_SYSTEM_DIRECTORIES 1" >>confdefs.h
|
|
+
|
|
+fi
|
|
+
|
|
# Substitute configuration variables
|
|
|
|
|
|
Index: gcc-4.9-20140316/gcc/configure.ac
|
|
===================================================================
|
|
--- gcc-4.9-20140316.orig/gcc/configure.ac
|
|
+++ gcc-4.9-20140316/gcc/configure.ac
|
|
@@ -5366,6 +5366,16 @@ AC_ARG_ENABLE(version-specific-runtime-l
|
|
[specify that runtime libraries should be
|
|
installed in a compiler-specific directory])])
|
|
|
|
+AC_ARG_ENABLE([poison-system-directories],
|
|
+ AS_HELP_STRING([--enable-poison-system-directories],
|
|
+ [warn for use of native system header directories]),,
|
|
+ [enable_poison_system_directories=no])
|
|
+if test "x${enable_poison_system_directories}" = "xyes"; then
|
|
+ AC_DEFINE([ENABLE_POISON_SYSTEM_DIRECTORIES],
|
|
+ [1],
|
|
+ [Define to warn for use of native system header directories])
|
|
+fi
|
|
+
|
|
# Substitute configuration variables
|
|
AC_SUBST(subdirs)
|
|
AC_SUBST(srcdir)
|
|
Index: gcc-4.9-20140316/gcc/doc/invoke.texi
|
|
===================================================================
|
|
--- gcc-4.9-20140316.orig/gcc/doc/invoke.texi
|
|
+++ gcc-4.9-20140316/gcc/doc/invoke.texi
|
|
@@ -260,6 +260,7 @@ Objective-C and Objective-C++ Dialects}.
|
|
-Woverlength-strings -Wpacked -Wpacked-bitfield-compat -Wpadded @gol
|
|
-Wparentheses -Wpedantic-ms-format -Wno-pedantic-ms-format @gol
|
|
-Wpointer-arith -Wno-pointer-to-int-cast @gol
|
|
+-Wno-poison-system-directories @gol
|
|
-Wredundant-decls -Wno-return-local-addr @gol
|
|
-Wreturn-type -Wsequence-point -Wshadow @gol
|
|
-Wsign-compare -Wsign-conversion -Wfloat-conversion @gol
|
|
@@ -4230,6 +4231,14 @@ headers---for that, @option{-Wunknown-pr
|
|
for most targets, it is made up of code and thus requires the stack
|
|
to be made executable in order for the program to work properly.
|
|
|
|
+@item -Wno-poison-system-directories
|
|
+@opindex Wno-poison-system-directories
|
|
+Do not warn for @option{-I} or @option{-L} options using system
|
|
+directories such as @file{/usr/include} when cross compiling. This
|
|
+option is intended for use in chroot environments when such
|
|
+directories contain the correct headers and libraries for the target
|
|
+system rather than the host.
|
|
+
|
|
@item -Wfloat-equal
|
|
@opindex Wfloat-equal
|
|
@opindex Wno-float-equal
|
|
Index: gcc-4.9-20140316/gcc/gcc.c
|
|
===================================================================
|
|
--- gcc-4.9-20140316.orig/gcc/gcc.c
|
|
+++ gcc-4.9-20140316/gcc/gcc.c
|
|
@@ -764,6 +764,8 @@ proper position among the other output f
|
|
"%{fuse-ld=*:-fuse-ld=%*}\
|
|
%X %{o*} %{e*} %{N} %{n} %{r}\
|
|
%{s} %{t} %{u*} %{z} %{Z} %{!nostdlib:%{!nostartfiles:%S}} " VTABLE_VERIFICATION_SPEC " \
|
|
+ %{Wno-poison-system-directories:--no-poison-system-directories}\
|
|
+ %{Werror=poison-system-directories:--error-poison-system-directories}\
|
|
%{static:} %{L*} %(mfwrap) %(link_libgcc) " SANITIZER_EARLY_SPEC " %o\
|
|
%{fopenmp|ftree-parallelize-loops=*:%:include(libgomp.spec)%(link_gomp)}\
|
|
%{fgnu-tm:%:include(libitm.spec)%(link_itm)}\
|
|
Index: gcc-4.9-20140316/gcc/incpath.c
|
|
===================================================================
|
|
--- gcc-4.9-20140316.orig/gcc/incpath.c
|
|
+++ gcc-4.9-20140316/gcc/incpath.c
|
|
@@ -28,6 +28,7 @@
|
|
#include "intl.h"
|
|
#include "incpath.h"
|
|
#include "cppdefault.h"
|
|
+#include "diagnostic-core.h"
|
|
|
|
/* Microsoft Windows does not natively support inodes.
|
|
VMS has non-numeric inodes. */
|
|
@@ -382,6 +383,24 @@ merge_include_chains (const char *sysroo
|
|
}
|
|
fprintf (stderr, _("End of search list.\n"));
|
|
}
|
|
+
|
|
+#ifdef ENABLE_POISON_SYSTEM_DIRECTORIES
|
|
+ if (flag_poison_system_directories)
|
|
+ {
|
|
+ struct cpp_dir *p;
|
|
+
|
|
+ for (p = heads[QUOTE]; p; p = p->next)
|
|
+ {
|
|
+ if ((!strncmp (p->name, "/usr/include", 12))
|
|
+ || (!strncmp (p->name, "/usr/local/include", 18))
|
|
+ || (!strncmp (p->name, "/usr/X11R6/include", 18)))
|
|
+ warning (OPT_Wpoison_system_directories,
|
|
+ "include location \"%s\" is unsafe for "
|
|
+ "cross-compilation",
|
|
+ p->name);
|
|
+ }
|
|
+ }
|
|
+#endif
|
|
}
|
|
|
|
/* Use given -I paths for #include "..." but not #include <...>, and
|