964b1268f7
Also add a GCC12 patch for versions <2020.xx to device/.shared-patches/u-boot Signed-off-by: Ferass El Hafidi <vitali64pmemail@protonmail.com>
11 lines
386 B
Diff
11 lines
386 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -970,6 +970,8 @@
|
|
# Avoid 'Not enough room for program headers' error on binutils 2.28 onwards.
|
|
LDFLAGS_u-boot += $(call ld-option, --no-dynamic-linker)
|
|
|
|
+LDFLAGS_u-boot += -z notext $(call ld-option, --apply-dynamic-relocs)
|
|
+
|
|
ifeq ($(CONFIG_ARC)$(CONFIG_NIOS2)$(CONFIG_X86)$(CONFIG_XTENSA),)
|
|
LDFLAGS_u-boot += -Ttext $(CONFIG_SYS_TEXT_BASE)
|
|
endif
|