1c0ff6aa23
Later, the aports folder will probably get split up in its own repository. But right now this is simply convenient.
194 lines
6.8 KiB
Diff
194 lines
6.8 KiB
Diff
http://cgit.openembedded.org/openembedded-core/plain/meta/recipes-devtools/gcc/gcc-6.1/0010-gcc-poison-system-directories.patch
|
|
|
|
From d76250323dad69212c958e4857a98d99ab51a39e Mon Sep 17 00:00:00 2001
|
|
From: Khem Raj <raj.khem@gmail.com>
|
|
Date: Fri, 29 Mar 2013 08:59:00 +0400
|
|
Subject: [PATCH 10/46] gcc: poison-system-directories
|
|
|
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
|
|
Upstream-Status: Inappropriate [distribution: codesourcery]
|
|
---
|
|
gcc/common.opt | 4 ++++
|
|
gcc/config.in | 6 ++++++
|
|
gcc/configure | 16 ++++++++++++++++
|
|
gcc/configure.ac | 10 ++++++++++
|
|
gcc/doc/invoke.texi | 9 +++++++++
|
|
gcc/gcc.c | 2 ++
|
|
gcc/incpath.c | 19 +++++++++++++++++++
|
|
7 files changed, 66 insertions(+)
|
|
|
|
diff --git a/gcc/common.opt b/gcc/common.opt
|
|
index 67048db..733185c 100644
|
|
--- a/gcc/common.opt
|
|
+++ b/gcc/common.opt
|
|
@@ -659,6 +659,10 @@ Wreturn-local-addr
|
|
Common Var(warn_return_local_addr) Init(1) Warning
|
|
Warn about returning a pointer/reference to a local or temporary variable.
|
|
|
|
+Wpoison-system-directories
|
|
+Common Var(flag_poison_system_directories) Init(1) Warning
|
|
+Warn for -I and -L options using system directories if cross compiling
|
|
+
|
|
Wshadow
|
|
Common Var(warn_shadow) Warning
|
|
Warn when one local variable shadows another.
|
|
diff --git a/gcc/config.in b/gcc/config.in
|
|
index 115cb61..105b30f 100644
|
|
--- a/gcc/config.in
|
|
+++ b/gcc/config.in
|
|
@@ -187,6 +187,12 @@
|
|
#endif
|
|
|
|
|
|
+/* Define to warn for use of native system header directories */
|
|
+#ifndef USED_FOR_TARGET
|
|
+#undef ENABLE_POISON_SYSTEM_DIRECTORIES
|
|
+#endif
|
|
+
|
|
+
|
|
/* Define if you want all operations on RTL (the basic data structure of the
|
|
optimizer and back end) to be checked for dynamic type safety at runtime.
|
|
This is quite expensive. */
|
|
diff --git a/gcc/configure b/gcc/configure
|
|
index 1c6e340..8f83152 100755
|
|
--- a/gcc/configure
|
|
+++ b/gcc/configure
|
|
@@ -942,6 +942,7 @@ with_system_zlib
|
|
enable_maintainer_mode
|
|
enable_link_mutex
|
|
enable_version_specific_runtime_libs
|
|
+enable_poison_system_directories
|
|
enable_plugin
|
|
enable_host_shared
|
|
enable_libquadmath_support
|
|
@@ -1681,6 +1682,8 @@ Optional Features:
|
|
--enable-version-specific-runtime-libs
|
|
specify that runtime libraries should be installed
|
|
in a compiler-specific directory
|
|
+ --enable-poison-system-directories
|
|
+ warn for use of native system header directories
|
|
--enable-plugin enable plugin support
|
|
--enable-host-shared build host code as shared libraries
|
|
--disable-libquadmath-support
|
|
@@ -28908,6 +28911,19 @@ if test "${enable_version_specific_runtime_libs+set}" = set; then :
|
|
fi
|
|
|
|
|
|
+# Check whether --enable-poison-system-directories was given.
|
|
+if test "${enable_poison_system_directories+set}" = set; then :
|
|
+ enableval=$enable_poison_system_directories;
|
|
+else
|
|
+ enable_poison_system_directories=no
|
|
+fi
|
|
+
|
|
+if test "x${enable_poison_system_directories}" = "xyes"; then
|
|
+
|
|
+$as_echo "#define ENABLE_POISON_SYSTEM_DIRECTORIES 1" >>confdefs.h
|
|
+
|
|
+fi
|
|
+
|
|
# Substitute configuration variables
|
|
|
|
|
|
diff --git a/gcc/configure.ac b/gcc/configure.ac
|
|
index 6c1dcd9..0fccaef 100644
|
|
--- a/gcc/configure.ac
|
|
+++ b/gcc/configure.ac
|
|
@@ -5861,6 +5861,16 @@ AC_ARG_ENABLE(version-specific-runtime-libs,
|
|
[specify that runtime libraries should be
|
|
installed in a compiler-specific directory])])
|
|
|
|
+AC_ARG_ENABLE([poison-system-directories],
|
|
+ AS_HELP_STRING([--enable-poison-system-directories],
|
|
+ [warn for use of native system header directories]),,
|
|
+ [enable_poison_system_directories=no])
|
|
+if test "x${enable_poison_system_directories}" = "xyes"; then
|
|
+ AC_DEFINE([ENABLE_POISON_SYSTEM_DIRECTORIES],
|
|
+ [1],
|
|
+ [Define to warn for use of native system header directories])
|
|
+fi
|
|
+
|
|
# Substitute configuration variables
|
|
AC_SUBST(subdirs)
|
|
AC_SUBST(srcdir)
|
|
diff --git a/gcc/doc/invoke.texi b/gcc/doc/invoke.texi
|
|
index 821f8fd..8bb49e7 100644
|
|
--- a/gcc/doc/invoke.texi
|
|
+++ b/gcc/doc/invoke.texi
|
|
@@ -284,6 +284,7 @@ Objective-C and Objective-C++ Dialects}.
|
|
-Wparentheses -Wno-pedantic-ms-format @gol
|
|
-Wplacement-new -Wplacement-new=@var{n} @gol
|
|
-Wpointer-arith -Wno-pointer-to-int-cast @gol
|
|
+-Wno-poison-system-directories @gol
|
|
-Wno-pragmas -Wredundant-decls -Wno-return-local-addr @gol
|
|
-Wreturn-type -Wsequence-point -Wshadow -Wno-shadow-ivar @gol
|
|
-Wshift-overflow -Wshift-overflow=@var{n} @gol
|
|
@@ -4723,6 +4724,14 @@ made up of data only and thus requires no special treatment. But, for
|
|
most targets, it is made up of code and thus requires the stack to be
|
|
made executable in order for the program to work properly.
|
|
|
|
+@item -Wno-poison-system-directories
|
|
+@opindex Wno-poison-system-directories
|
|
+Do not warn for @option{-I} or @option{-L} options using system
|
|
+directories such as @file{/usr/include} when cross compiling. This
|
|
+option is intended for use in chroot environments when such
|
|
+directories contain the correct headers and libraries for the target
|
|
+system rather than the host.
|
|
+
|
|
@item -Wfloat-equal
|
|
@opindex Wfloat-equal
|
|
@opindex Wno-float-equal
|
|
diff --git a/gcc/gcc.c b/gcc/gcc.c
|
|
index 1af5920..4cfef7f 100644
|
|
--- a/gcc/gcc.c
|
|
+++ b/gcc/gcc.c
|
|
@@ -1017,6 +1017,8 @@ proper position among the other output files. */
|
|
"%{fuse-ld=*:-fuse-ld=%*} " LINK_COMPRESS_DEBUG_SPEC \
|
|
"%X %{o*} %{e*} %{N} %{n} %{r}\
|
|
%{s} %{t} %{u*} %{z} %{Z} %{!nostdlib:%{!nostartfiles:%S}} \
|
|
+ %{Wno-poison-system-directories:--no-poison-system-directories} \
|
|
+ %{Werror=poison-system-directories:--error-poison-system-directories} \
|
|
%{static:} %{L*} %(mfwrap) %(link_libgcc) " \
|
|
VTABLE_VERIFICATION_SPEC " " SANITIZER_EARLY_SPEC " %o " CHKP_SPEC " \
|
|
%{fopenacc|fopenmp|%:gt(%{ftree-parallelize-loops=*:%*} 1):\
|
|
diff --git a/gcc/incpath.c b/gcc/incpath.c
|
|
index ea40f4a..856da41 100644
|
|
--- a/gcc/incpath.c
|
|
+++ b/gcc/incpath.c
|
|
@@ -26,6 +26,7 @@
|
|
#include "intl.h"
|
|
#include "incpath.h"
|
|
#include "cppdefault.h"
|
|
+#include "diagnostic-core.h"
|
|
|
|
/* Microsoft Windows does not natively support inodes.
|
|
VMS has non-numeric inodes. */
|
|
@@ -381,6 +382,24 @@ merge_include_chains (const char *sysroot, cpp_reader *pfile, int verbose)
|
|
}
|
|
fprintf (stderr, _("End of search list.\n"));
|
|
}
|
|
+
|
|
+#ifdef ENABLE_POISON_SYSTEM_DIRECTORIES
|
|
+ if (flag_poison_system_directories)
|
|
+ {
|
|
+ struct cpp_dir *p;
|
|
+
|
|
+ for (p = heads[QUOTE]; p; p = p->next)
|
|
+ {
|
|
+ if ((!strncmp (p->name, "/usr/include", 12))
|
|
+ || (!strncmp (p->name, "/usr/local/include", 18))
|
|
+ || (!strncmp (p->name, "/usr/X11R6/include", 18)))
|
|
+ warning (OPT_Wpoison_system_directories,
|
|
+ "include location \"%s\" is unsafe for "
|
|
+ "cross-compilation",
|
|
+ p->name);
|
|
+ }
|
|
+ }
|
|
+#endif
|
|
}
|
|
|
|
/* Use given -I paths for #include "..." but not #include <...>, and
|
|
--
|
|
2.8.2
|
|
|