pmaports/luna/luna-webappmanager/remove-systemd.patch
Alex Roth 04d73a5824 Add packages and configuration changes to allow Luna to start in QEMU (#1016)
* Added a lot more Luna packages. It is now possible to start Luna, complete the first use app, and use the system. ARM support still broken.
* Cleanup & testing fixes. Starting in a fresh qemu environment works, but isn't quite deterministic. See wiki page for details
2017-12-17 18:25:59 +00:00

35 lines
991 B
Diff

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 23d7631..1163299 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,7 +46,7 @@ find_package(PkgConfig "0.22" REQUIRED)
pkg_check_modules(GLIB2 glib-2.0 REQUIRED)
pkg_check_modules(LS2 luna-service2 REQUIRED)
-pkg_check_modules(SYSTEMD libsystemd REQUIRED)
+pkg_check_modules(SYSTEMD libsystemd OPTIONAL)
pkg_check_modules(PBNJSON_C pbnjson_c REQUIRED)
pkg_check_modules(LUNA_SYSMGR_COMMON LunaSysMgrCommon REQUIRED)
pkg_check_modules(LUNA_PREFS luna-prefs REQUIRED)
diff --git a/src/main.cpp b/src/main.cpp
index c79782d..fe48ae4 100644
--- a/src/main.cpp
+++ b/src/main.cpp
@@ -21,7 +21,6 @@
#include <QtGlobal>
#include <glib.h>
-#include <systemd/sd-daemon.h>
#include <LocalePreferences.h>
@@ -140,9 +139,6 @@ int main(int argc, char **argv)
LocalePreferences::instance();
luna::SystemTime::instance();
- if (option_systemd)
- sd_notify(0, "READY=1");
-
webAppManager.exec();
cleanup: