pmaports/main/gcc6/ada-aarch64-multiarch.patch
Oliver Smith 737cff798a
Add gcc6 aport
Based on the last version from Alpine, but installed to /usr/gcc6 and
with pretty much everything disabled except for the C compiler.

We can probably throw out a lot of patches, and make the APKBUILD much
smaller. But let's focus on making it possible to compile old kernels
again first. There's still a lot to do for that, see #103.
2018-11-27 07:47:11 +01:00

16 lines
707 B
Diff

--- gcc-6.4.0/gcc/ada/gcc-interface/Makefile.in.orig
+++ gcc-6.4.0/gcc/ada/gcc-interface/Makefile.in
@@ -2042,13 +2042,8 @@
system.ads<system-linux-x86_64.ads
## ^^ Note the above is a pretty-close placeholder.
- ifneq (,$(or $(filter aarch64-linux-gnu, $(shell $(GCC_FOR_TARGET) $(GNATLIBCFLAGS) -print-multiarch)), $(filter ../lib64, $(shell $(GCC_FOR_TARGET) $(GNATLIBCFLAGS) -print-multi-os-directory))))
LIBGNAT_TARGET_PAIRS = \
$(LIBGNAT_TARGET_PAIRS_COMMON) $(LIBGNAT_TARGET_PAIRS_64)
- else
- LIBGNAT_TARGET_PAIRS = \
- $(LIBGNAT_TARGET_PAIRS_COMMON) $(LIBGNAT_TARGET_PAIRS_32)
- endif
TOOLS_TARGET_PAIRS = \
mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb \